Make nsCharSeparatedTokenizer optionally treat formfeed as whitespace character, for SVG clients

RESOLVED DUPLICATE of bug 555559

Status

()

Core
XPCOM
RESOLVED DUPLICATE of bug 555559
8 years ago
7 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
See Bug 573316 comment 7.

Basically, when SVG code uses nsCharSeparatedTokenizer, we need it to treat the linefeed character as a whitespace character in isWhitespace. (Currently, that character isn't treated as whitespace.)
LF (Line feed, '\n', 0x0A, 10 in decimal)
CR (Carriage return, '\r', 0x0D, 13 in decimal)

http://hg.mozilla.org/mozilla-central/annotate/e0c8f11c3892/xpcom/ds/nsCharSeparatedTokenizer.h#l157 looks to me as if it does do linefeeds (as '\n')
(Reporter)

Comment 2

8 years ago
Sorry, you're correct -- I meant to say formfeed ('\f'), not line feed.
Summary: Make nsCharSeparatedTokenizer optionally treat linefeed as whitespace character, for SVG clients → Make nsCharSeparatedTokenizer optionally treat formfeed as whitespace character, for SVG clients
(Reporter)

Comment 3

7 years ago
Bug 555559 fixed this by making nsCharSeparatedTokenizerTemplate take an optional "IsWhitespace" template-argument.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 555559
You need to log in before you can comment on or make changes to this bug.