Closed Bug 573578 Opened 12 years ago Closed 12 years ago

fatvals+tracing: assert on Mochitest /js/src/xpconnect/tests/mochitest/test_bug462428.html

Categories

(Core :: JavaScript Engine, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: dmandelin, Assigned: dmandelin)

References

Details

Assertion failure: JS_StringHasBeenInterned(str), at c:\sources\fatval\js\src\jsapi.h:309
http://hg.mozilla.org/users/lwagner_mozilla.com/fatval/rev/ed42260c48fb

The cause was that jsval strings were being converted to jsids without interning. I believe this means there was actually an underlying bug before fatvals.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
We already have JS_ValueToId in jsapi.h -- that was what should have been used by quickstubs code.

/be
(In reply to comment #2)
> We already have JS_ValueToId in jsapi.h -- that was what should have been used
> by quickstubs code.
> 
> /be

Forgot about that one (which is a real duh--I've had to use it with other recent bugs here). I'll reopen until it's fixed the right way.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Luke picked up the API fixup when doing some other fixes.
Status: REOPENED → RESOLVED
Closed: 12 years ago12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.