Last Comment Bug 573733 - Rename mTabs to tabs in suite tabbrowser
: Rename mTabs to tabs in suite tabbrowser
Status: RESOLVED FIXED
:
Product: SeaMonkey
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: Trunk
: All All
: -- normal (vote)
: seamonkey2.1a2
Assigned To: Robert Kaiser
:
:
Mentors:
Depends on:
Blocks: SMtabAPI 577756
  Show dependency treegraph
 
Reported: 2010-06-22 07:33 PDT by Robert Kaiser
Modified: 2010-07-09 14:12 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
v1: rename all occurrences, add compatibility shim (23.62 KB, patch)
2010-06-22 07:55 PDT, Robert Kaiser
neil: review+
Details | Diff | Splinter Review

Description Robert Kaiser 2010-06-22 07:33:54 PDT
Firefox uses gBrowser.tabs, even the mochitest-browser-chrome harness uses that, and we also already use .mTabs outside of tabbrowser, which suggestes it should not have the m prefix that pretends to be internal.
Comment 1 Robert Kaiser 2010-06-22 07:55:22 PDT
Created attachment 453065 [details] [diff] [review]
v1: rename all occurrences, add compatibility shim

This should rename all our internal uses, and just as Firefox, adds a <property> for backwards compat.
Comment 2 neil@parkwaycc.co.uk 2010-06-22 08:13:36 PDT
Comment on attachment 453065 [details] [diff] [review]
v1: rename all occurrences, add compatibility shim

>     var tabs = [];
>-    var mTabs = this._tabbrowser.mTabs;
>+    var mTabs = this._tabbrowser.tabs;
That's confusing variable naming :-(
Comment 3 Robert Kaiser 2010-06-22 08:27:08 PDT
(In reply to comment #2)
> (From update of attachment 453065 [details] [diff] [review])
> >     var tabs = [];
> >-    var mTabs = this._tabbrowser.mTabs;
> >+    var mTabs = this._tabbrowser.tabs;
> That's confusing variable naming :-(

Switched to tabNodes per IRC discussion and pushed as http://hg.mozilla.org/comm-central/rev/a9126328c4a9

Note You need to log in before you can comment on or make changes to this bug.