Make mar generation steps dependent on having a previous complete mar to update from

RESOLVED FIXED

Status

P2
normal
RESOLVED FIXED
9 years ago
6 years ago

People

(Reporter: coop, Assigned: coop)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [updates][automation])

Attachments

(2 attachments)

Now that we've upgraded to buildbot 0.8.0, we can use Dependent steps to avoid the first-run problem we have right now with partial mar generation for new branches.

We can change the get_previous_mar_filename step to warnOnFailure, and change the remaining mar generation steps to run Dependent on the previousMarFilename property set by that initial step.
(Assignee)

Comment 1

9 years ago
Testing a patch in staging now that uses a bunch of doStepIf calls.
(Assignee)

Comment 2

9 years ago
Uses doStepIf to run the mar generation steps only when the previous complete mar is available on stage. If the previous mar is not found, the build goes orange (warning), but everything else still gets uploaded.

Tested successfully in staging for both en-US and l10n nightlies.
Attachment #454059 - Flags: review?(armenzg)

Updated

9 years ago
Attachment #454059 - Flags: review?(armenzg) → review+
(Assignee)

Updated

9 years ago
Blocks: 575307
(Assignee)

Comment 3

9 years ago
Comment on attachment 454059 [details] [diff] [review]
Makes mar generation steps conditional on finding the previous complete mar

http://hg.mozilla.org/build/buildbotcustom/rev/cdaaed009fde
Attachment #454059 - Flags: checked-in+
(Assignee)

Comment 4

9 years ago
pm03 didn't get it's buildbotcustom checkout updated before reconfig yesterday, so I've done that now and reconfig-ed again.
(Assignee)

Comment 5

9 years ago
The 1.9.2 win pt-PT nightly just went orange (expected) because it couldn't find the previous complete mar, but the new build/mar got uploaded successfully.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

9 years ago
Still getting exceptions, but I think we just need to set descriptions for the affected steps. Patch coming up.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 7

9 years ago
Adding a description overrides the default behavior of looking up all properties when setting the description. Tested on sm03.
Attachment #456107 - Flags: review?(armenzg)

Updated

9 years ago
Attachment #456107 - Flags: review?(armenzg) → review+
(Assignee)

Updated

9 years ago
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
Duplicate of this bug: 562042
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.