Closed Bug 574109 Opened 10 years ago Closed 10 years ago

failures in layout/reftests/editor/xul/ on windows 7 64-bit

Categories

(Core :: Layout, defect)

x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla2.0b1

People

(Reporter: bhearsum, Assigned: ehsan)

References

Details

Attachments

(2 files)

Attached file log
Failure log is attached
Ben, is this intermittent?
Not intermittent, happens every time.
Looks like a height difference.  It really surprises me that the default height of text boxes are different in these platforms.  Do we have any desktop settings changed on those machines at all?
So, the problem here is that oscpu on Windows 64 bit is something like "Windows NT 6.1; Win64; x64", so the $ at the end of the oscpu regex causes these tests to actually run on 64-bit OSes, which is not what we want.
Attached patch Patch (v1)Splinter Review
Assignee: nobody → ehsan
Status: NEW → ASSIGNED
Attachment #453522 - Flags: review?(roc)
Duplicate of this bug: 574110
Summary: failures in {,empty}autocomplete-1.xul on 64-bit windows 7 → failures in layout/reftests/editor/xul/ on windows 7 64-bit
http://hg.mozilla.org/mozilla-central/rev/14c527450632
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a6
Thanks for fixing this Ehsan.
(In reply to comment #8)
> Thanks for fixing this Ehsan.

Sure.  It would be great if you could verify it though, since I basically just wrote the patch and hoped that it works!  ;-)
You need to log in before you can comment on or make changes to this bug.