Closed Bug 574111 Opened 11 years ago Closed 11 years ago

crash in font-face/underline-offset-change-2.html on 64-bit windows 7 [@ TTDeleteEmbeddedFont]

Categories

(Core :: Graphics, defect)

x86_64
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: bhearsum, Assigned: m_kato)

References

Details

(Keywords: crash, intermittent-failure)

Crash Data

TEST-UNEXPECTED-FAIL | http://localhost:4444/1277311714515/96/font-face/underline-offset-change-2.html | Exited with code -1073740940 during test run
Was there a stack in the log?
No stack :(.

Closest thing to it was:
Traceback (most recent call last):
  File "reftest/runreftest.py", line 267, in <module>
    main()
  File "reftest/runreftest.py", line 264, in main
    sys.exit(reftest.runTests(args[0], options))
  File "reftest/runreftest.py", line 161, in runTests
    timeout=options.timeout + 30.0)
  File "C:\talos-slave\mozilla-central-w764-opt-u-reftest\build\reftest\automation.py", line 770, in runApp
    self.checkForZombies(processLog)
  File "C:\talos-slave\mozilla-central-w764-opt-u-reftest\build\reftest\automation.py", line 702, in checkForZombies
    if self.isPidAlive(processPID):
  File "C:\talos-slave\mozilla-central-w764-opt-u-reftest\build\reftest\automation.py", line 535, in isPidAlive
    ctypes.windll.kernel32.GetExitCodeProcess(pHandle, self.ctypes.byref(pExitCode))
AttributeError: 'Automation' object has no attribute 'ctypes'


But I don't think that's relevant to the failure.
I can't reproduce this crash on my system with the tinderbox build or my own build.
Turns out this is somewhat intermittent, happens about 50% of the time. I'm running on a test machine and trying to get a stack.
Whiteboard: [orange]
I haven't been able to get a stack on the test machine with windbg. I can't even get it to attach to the process, in fact. When I get back from PTO (next week) i'm going to install it on my mini locally and try with visual studio.
-1073740940 = C0000374 = STATUS_HEAP_CORRUPTION

So, I believe that this is python issue that installed on Tinderbox.

Ben, what version and bit of python on Tinderbox?
We're running the Python 2.5 included with MozillaBuild. It's a 32-bit version.
I don't think this is a crash in Python. The Python traceback you're seeing there is from an unrelated bug (it was fixed in bug 574912). I believe the exit code is actually the Firefox exit code.
When I used Python 2.5 32-bit, I could reproduce this.

0:000> r
rax=00000000001df1e0 rbx=0000000000000000 rcx=00000000001df598
rdx=0000000000000000 rsi=0000000000000000 rdi=0000000002000444
rip=000007fef7722573 rsp=00000000001df0f0 rbp=0000000006463fc0
 r8=0000000000000000  r9=0000000000000000 r10=0000000006615358
r11=0000000000000000 r12=0000000000000001 r13=00000000001df618
r14=0000000000000006 r15=0000000000000042
iopl=0         nv up ei pl zr na po nc
cs=0033  ss=002b  ds=002b  es=002b  fs=0053  gs=002b             efl=00010246
t2embed!TTDeleteEmbeddedFont+0x6b:
000007fe`f7722573 48399fa8030000  cmp     qword ptr [rdi+3A8h],rbx ds:00000000`0
20007ec=????????????????

0:000> k
Child-SP          RetAddr           Call Site
00000000`001df0f0 000007fe`ef9e8b54 t2embed!TTDeleteEmbeddedFont+0x6b
00000000`001df5e0 000007fe`ef9c7446 xul!WinUserFontData::`scalar deleting destru
ctor'+0x38
00000000`001df610 000007fe`ef9ea2ec xul!gfxFontEntry::~gfxFontEntry+0x2a [c:\wor
kspace\mozilla-hg\mozilla-win64\gfx\thebes\gfxfont.cpp @ 98]
00000000`001df650 000007fe`ef9c7d70 xul!GDIFontEntry::`scalar deleting destructo
r'+0x14
00000000`001df680 000007fe`ef9ec2b8 xul!gfxFont::~gfxFont+0x118 [c:\workspace\mo
zilla-hg\mozilla-win64\gfx\thebes\gfxfont.cpp @ 953]
00000000`001df6d0 000007fe`ef9c1e6e xul!gfxGDIFont::`scalar deleting destructor'
+0x14
00000000`001df700 000007fe`ef12cccb xul!gfxFontCache::DestroyFont+0x66 [c:\works
pace\mozilla-hg\mozilla-win64\gfx\thebes\gfxfont.cpp @ 911]
00000000`001df740 000007fe`ef322ba9 xul!nsExpirationTracker<imgCacheEntry,3>::Ag
eOneGeneration+0x5b [c:\workspace\mozilla-hg\objdir-win64\dist\include\nsexpirat
iontracker.h @ 211]
00000000`001df770 000007fe`ef987864 xul!nsExpirationTracker<gfxTextRun,3>::Timer
Callback+0x11 [c:\workspace\mozilla-hg\objdir-win64\dist\include\nsexpirationtra
cker.h @ 302]
00000000`001df7a0 000007fe`ef987a6b xul!nsTimerImpl::Fire+0xd4 [c:\workspace\moz
illa-hg\mozilla-win64\xpcom\threads\nstimerimpl.cpp @ 428]
00000000`001df7d0 000007fe`ef980e5b xul!nsTimerEvent::Run+0x27 [c:\workspace\moz
illa-hg\mozilla-win64\xpcom\threads\nstimerimpl.cpp @ 521]
00000000`001df800 000007fe`ef95c424 xul!nsThread::ProcessNextEvent+0xef [c:\work
space\mozilla-hg\mozilla-win64\xpcom\threads\nsthread.cpp @ 547]
00000000`001df850 000007fe`efad72f5 xul!NS_ProcessNextEvent_P+0x38 [c:\workspace
\mozilla-hg\objdir-win64\xpcom\build\nsthreadutils.cpp @ 250]
00000000`001df880 000007fe`ef9a64b2 xul!mozilla::ipc::MessagePump::Run+0xd5 [c:\
workspace\mozilla-hg\mozilla-win64\ipc\glue\messagepump.cpp @ 143]
00000000`001df8d0 000007fe`ef9a67bf xul!MessageLoop::RunHandler+0x3a [c:\workspa
ce\mozilla-hg\mozilla-win64\ipc\chromium\src\base\message_loop.cc @ 203]
00000000`001df900 000007fe`ef87bc1b xul!MessageLoop::Run+0x23 [c:\workspace\mozi
lla-hg\mozilla-win64\ipc\chromium\src\base\message_loop.cc @ 176]
00000000`001df960 000007fe`ef74a437 xul!nsBaseAppShell::Run+0x33 [c:\workspace\m
ozilla-hg\mozilla-win64\widget\src\xpwidgets\nsbaseappshell.cpp @ 181]
00000000`001df990 000007fe`ef048d0f xul!nsAppStartup::Run+0x23 [c:\workspace\moz
illa-hg\mozilla-win64\toolkit\components\startup\src\nsappstartup.cpp @ 192]
00000000`001df9c0 00000001`3f74140f xul!XRE_main+0x10a3 [c:\workspace\mozilla-hg
\mozilla-win64\toolkit\xre\nsapprunner.cpp @ 3605]
00000000`001dfd50 00000001`3f74159f firefox!NS_internal_main+0x1db [c:\workspace
\mozilla-hg\mozilla-win64\browser\app\nsbrowserapp.cpp @ 159]
Component: Layout → Graphics
QA Contact: layout → thebes
Assignee: nobody → m_kato
Blocks: 438871
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1279267877.1279269024.21768.gz
Rev3 WINNT 6.1 mozilla-central opt test reftest on 2010/07/16 01:11:17
Makoto, is there anything I can do to help debug or fix this? I'm a bit lost on the status.
Severity: normal → critical
Keywords: crash
Summary: crash in font-face/underline-offset-change-2.html on 64-bit windows 7 → crash in font-face/underline-offset-change-2.html on 64-bit windows 7 [@ TTDeleteEmbeddedFont]
This has already been fixed I believe.  Please reconfirm and comment if you think it has not been fixed, otherwise I think we should resolve this.
I cannot reproduce on current test and this doesn't occurs on tinderbox test.  font code has various changes, so I marked as WFM.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ TTDeleteEmbeddedFont]
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.