Closed Bug 574332 Opened 9 years ago Closed 9 years ago

[e10s] Convert sendSyncMessage calls to sendAsyncMessage

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mbrubeck, Assigned: mbrubeck)

References

Details

Attachments

(1 file, 2 obsolete files)

We are using sendSyncMessage in content.js and bindings/browser.js, because our browser-chrome tests break when using sendAsyncMessage.

The current tests fail on with sendAsyncMessage because "waitFor(... tab.isLoading() == false ...)" finishes too soon (the new tab has loading==false on creation).

Note: This bug is about fixing the tests for non-IPC builds.  We'll file other bugs as needed for making tests run under multi-process.
Attached patch WIP (obsolete) — Splinter Review
Making some progress, temporarily hacking around some brokenness:

* Explicitly ignore pageloads of about:blank.  This fixes most (all?) of the problems caused by sendAsyncMessage.  Firefox does this, e.g. http://mxr.mozilla.org/mozilla-central/source/toolkit/content/tests/browser/browser_save_resend_postdata.js#62

* FormHelper and SelectHelper tests are broken by bug 566288.  Disabled them for now since they were also interfering with other tests.

* Had to set browser.tabs.remote=false or build with --disable-ipc.

* Viewport metadata tests are still broken, haven't fixed this yet.
Attached patch WIP 2 (obsolete) — Splinter Review
Down to 7 failures.

FormHelper, SelectHelper and browser_click_content tests are broken by recent changes (with or without sendAsyncMessage).  Disabled them for now.

Some tests in browser_preferences are failing with or without sendAsyncMessage, need to investigate.

A few tests in browser_navigation are still failing only with sendAsyncMessage, need to investigate.
Attachment #453917 - Attachment is obsolete: true
Attached patch patchSplinter Review
Fixed the remaining browser_navigation tests.  Now we can switch to sendAsyncMessage without causing any new test failures.

There are still tests failing (in browser_preferences_basic) and disabled (in browser_FormAssistant and browser_select).  These are all tests that were already failing before this change.  The FormHelper/SelectHelper tests are disabled by this patch because they caused long timeouts that made it hard to work on the test suite.

I'll file followup bugs to enable and fix the remaining failing tests.
Attachment #454129 - Attachment is obsolete: true
Attachment #454155 - Flags: review?(mark.finkle)
Followup bug for FormHelper/SelectHelper: bug 574840
Followup bug (with patch) for browser_preferences_basic: bug 574857
Comment on attachment 454155 [details] [diff] [review]
patch

Great work
Attachment #454155 - Flags: review?(mark.finkle) → review+
Depends on: 574840
Depends on: 574857
Depends on: 575808
http://hg.mozilla.org/mobile-browser/rev/ce340d18a9d9
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.