Need to pass a PRBool to ConfirmEx's checkValue parameter

RESOLVED FIXED

Status

MailNews Core
Backend
--
major
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: neil@parkwaycc.co.uk)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

8 years ago
Before bug 563274 the prompting code was written in C++ and specifically did not attempt to use the checkValue parameter if no checkMsg string was provided. Unfortuantely we no longer have that luxury. In fact, we have to pass an initialised PRBool, so there are six call sites that need to be fixed.

I originally noticed this trying to delete a local folder; I haven't actually attempted to verify the fix for any of the other call sites.
(Assignee)

Comment 1

8 years ago
Created attachment 453833 [details] [diff] [review]
Proposed patch
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #453833 - Flags: superreview?(bienvenu)
Attachment #453833 - Flags: review?
(Assignee)

Updated

8 years ago
Attachment #453833 - Flags: review? → review?(bienvenu)
(Assignee)

Comment 2

8 years ago
Created attachment 453836 [details] [diff] [review]
Include nsIPromptService::PromptUsernameAndPassword

Most callers use nsIAuthPrompt which does not have this issue.
(This also goes for the some of the other Prompt function calls.)
Attachment #453833 - Attachment is obsolete: true
Attachment #453836 - Flags: superreview?(bienvenu)
Attachment #453836 - Flags: review?(bienvenu)
Attachment #453833 - Flags: superreview?(bienvenu)
Attachment #453833 - Flags: review?(bienvenu)

Updated

8 years ago
Attachment #453836 - Flags: superreview?(bienvenu)
Attachment #453836 - Flags: superreview+
Attachment #453836 - Flags: review?(bienvenu)
Attachment #453836 - Flags: review+
(Assignee)

Comment 3

8 years ago
Pushed changeset f27e030e9a14 to comm-central.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Duplicate of this bug: 573591

Comment 5

8 years ago
Pushed as http://hg.mozilla.org/comm-central/rev/51b6b3c86072 to the 2.1a2 relbranch, so this is fixed there (in build2) as well.
You need to log in before you can comment on or make changes to this bug.