Closed Bug 574813 Opened 9 years ago Closed 8 years ago

cannot type in the field that has focus/cursor after sound is played with QuickTime plugin (firefox 3.6.4)

Categories

(Firefox :: General, defect, major)

3.6 Branch
x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: sergey, Unassigned)

Details

User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.4) Gecko/20100611 Firefox/3.6.4 ( .NET CLR 3.5.30729)

Page has text input field and a button. When button is pressed, it should play the sound (with quicktime plugin) and then set the focus to the field. You can see the cursor on the field but cannot type anything. Broken in firefox version 3.6.4, worked fine in prevoius versions

Reproducible: Always

Steps to Reproduce:
Following example code worked fine prior to 3.6.4 (when button is clicked it should play the sound (using quicktime plugin) and set the focus to the text field. You can see the cursor, but cannot type):
<html>
<head>
<title></title>
<script type="text/javascript">
    function PlaySound() {
        document.getElementById("sounddiv").innerHTML = "<embed src=click.wav hidden=true autostart=true loop=false>";
    }
    function DoAction() {
        PlaySound();
        document.getElementById("fieldid").focus();
    }
</script>
</head>
<body>
    <input type="text" id="fieldid" />
    <input type="button" onclick="DoAction();" value="test" />
    <div style="visibility: hidden;" id="sounddiv"></div>
</body>
</html>
Version: unspecified → 3.6 Branch
Reporter, Firefox 4.0.1 has been released, and it features significant improvements over previous releases. Can you please update to Firefox 4.0.1 or later, and retest your bug? Please also create a fresh profile (
http://support.mozilla.com/kb/Managing+profiles), update your plugins (Flash, Java, Quicktime, Reader, etc) and update your graphics driver and Operating system to the latest versions available. 

If you still continue to see this issue, please comment. If you do not, please close this bug as RESOLVED > WORKSFORME

filter: prefirefox4uncobugs
No longer a problem in Firefox 4.0.1
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.