Firefox doesn't compile anymore without plugins support!!!

RESOLVED INCOMPLETE

Status

()

defect
--
major
RESOLVED INCOMPLETE
9 years ago
2 years ago

People

(Reporter: honeybeenet, Unassigned)

Tracking

1.9.2 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.10) Gecko/2009042700 SUSE/3.0.10-2.1 Firefox/3.0.10
Build Identifier: Firefox 3.6.4

This new version of Firefox, 3.6.4, doesn't work anymore!!!!
I'm unable to build it without the support for plugins!!!

This is the error i'm getting every time:
../../staticlib/libdomplugins_s.a(PluginModuleChild.o): In function `mozilla::plugins::PluginModuleChild::Init(std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, int, MessageLoop*, IPC::Channel*)':
PluginModuleChild.cpp:(.text+0x25d2): undefined reference to `nsPluginFile::nsPluginFile(nsIFile*)'
PluginModuleChild.cpp:(.text+0x25e3): undefined reference to `nsPluginFile::LoadPlugin(PRLibrary*&)'
PluginModuleChild.cpp:(.text+0x265b): undefined reference to `nsPluginFile::~nsPluginFile()'
../../staticlib/libdomplugins_s.a(PluginModuleParent.o): In function `mozilla::plugins::PluginModuleParent::AnswerNPN_GetValue_WithBoolReturn(NPNVariable const&, short*, bool*)':
PluginModuleParent.cpp:(.text+0x288): undefined reference to `mozilla::plugins::parent::_getvalue(_NPP*, NPNVariable, void*)'
../../staticlib/libdomplugins_s.a(PluginModuleParent.o): In function `mozilla::plugins::PluginModuleParent::GetIdentifierForNPIdentifier(void*)':
PluginModuleParent.cpp:(.text+0x527): undefined reference to `mozilla::plugins::parent::_identifierisstring(void*)'
PluginModuleParent.cpp:(.text+0x537): undefined reference to `mozilla::plugins::parent::_utf8fromidentifier(void*)'
PluginModuleParent.cpp:(.text+0x559): undefined reference to `mozilla::plugins::parent::_intfromidentifier(void*)'
../../staticlib/libdomplugins_s.a(PluginModuleParent.o): In function `mozilla::plugins::PluginModuleParent::AllocPPluginIdentifier(nsCString const&, int const&)':
PluginModuleParent.cpp:(.text+0xade): undefined reference to `mozilla::plugins::parent::_getintidentifier(int)'
PluginModuleParent.cpp:(.text+0xaea): undefined reference to `mozilla::plugins::parent::_getstringidentifier(char const*)'
../../staticlib/libdomplugins_s.a(PluginModuleParent.o): In function `mozilla::plugins::PluginModuleParent::NotifyPluginCrashed()':
PluginModuleParent.cpp:(.text+0xbcd): undefined reference to `nsNPAPIPlugin::PluginCrashed(nsAString_internal const&, nsAString_internal const&)'
/usr/bin/ld: libxul.so: hidden symbol `nsPluginFile::~nsPluginFile()' isn't defined
/usr/bin/ld: final link failed: Nonrepresentable section on output
collect2: ld returned 1 exit status
make[3]: *** [libxul.so] Error 1
make[3]: Leaving directory `/home/hb/Documents/factorbee/tmp/mozilla-1.9.2/toolkit/library'
make[2]: *** [libs_tier_toolkit] Error 2
make[2]: Leaving directory `/home/hb/Documents/factorbee/tmp/mozilla-1.9.2'
make[1]: *** [tier_toolkit] Error 2
make[1]: Leaving directory `/home/hb/Documents/factorbee/tmp/mozilla-1.9.2'
make: *** [default] Error 2


-------
I ain't sure, but maybe it's due to the "--disable-plugins" switch, which worked very well in and until firefox 3.6.3!!!

This is the full configure command line i am using:
./configure --enable-application=browser --enable-optimize=-Os --enable-default-toolkit=cairo-gtk2 --enable-pango --enable-libxul --disable-debug --disable-javaxpcom --enable-strip --disable-tests --disable-crashreporter --disable-safe-browsing --disable-plugins --disable-updater --disable-installer --disable-update-packaging --disable-necko-wifi --disable-parental-controls --disable-help-viewer --disable-logging --prefix=/tmp/factorbee/app/firefox --with-default-mozilla-five-home=/tmp/factorbee/app/firefox/lib-firefox --with-system-zlib=/tmp/factorbee/app/zlib/lib --enable-extensions=default,-java,-metrics,-reporter,-jssh

I think that the new system to manage plugins in Firefox is to blame!!!
It's very important to fix this bug, because Firefox without plugins is much more safe for privacy and i'm using it in my Tor Browser Bundle!!!!

bye!!!!!!!!!!
~bee!!!!!!

Reproducible: Always

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 573101
Reopening.  Bug 573101 is a run-time JavaScript error, while this is a compile-time error.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Version: unspecified → 1.9.2 Branch
It's not clear to me that this compile time switch is supported anymore...  Benjamin?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

9 years ago
I think that you can --disable-ipc and this will work. I don't know if we care enough about this configuration to fix it "for real".
(Reporter)

Comment 5

9 years ago
This is what makes me dislike MOZILLA!!!!!!!!!!!!!!!!!

You drop useful features without telling anything to anyone and without reasons!!!!! You should really read my comment here to get an idea!! https://blog.torproject.org/blog/firefox-private-browsing-mode-torbutton-and-fingerprinting#comment-6590

For once, try to make firefox working instead of continuously turning it into a fat pig, removing all the useful features!!!!!!

I don't know what "--disable-ipc" is all about and what's supposed to do (no info, no documentation to read about it), but i need to build firefox without the support for plugins (no support for Flash, java, etc!!!)
I think this bug to be related to the new feature of plugins "in a separated process" because i read:
PluginModuleChild.cpp:(.text+0x25d2): undefined reference to
`nsPluginFile::nsPluginFile(nsIFile*)'
so, it seems to me like the builds fail because there is something of wrong with the plug-ins system!!!!

Firefox without the support for plugins is very important for a TOR Browser Bundle!!!!!

So, my question is: how to build again Firefox having the same results i had before?!!! Without the support for plugins?!!! Will you fix this bug, or not?!! or is using the "--disable-ipc" equivalent to "--disable-plugins"???!!!!!!

yeah!! answer and thank you!!!

bye!!!!!!
~bee!!!
(In reply to comment #5)
> So, my question is: how to build again Firefox having the same results i had
> before?!!! Without the support for plugins?!!!

Use both --disable-ipc and --disable-plugins.
(Reporter)

Comment 7

9 years ago
Yeah!!!!!!!!! That's wonderful!! very great!!!!

I added "--disable-ipc" and Firefox builds again, and it seems to work just like it was before!!!!!!

THANK YOU MATT!!!!!!!

Bye!!!!!!
~bee!!!

Comment 8

2 years ago
Resolving old bugs which are likely not relevant any more, since NPAPI plugins are deprecated.
Status: NEW → RESOLVED
Last Resolved: 9 years ago2 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.