string.replace(/ /g, "") --> " line 33: missing } in compound statement"

VERIFIED WORKSFORME

Status

()

Core
JavaScript Engine
P3
normal
VERIFIED WORKSFORME
18 years ago
16 years ago

People

(Reporter: Jesse Ruderman, Assigned: rogerl (gone))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Steps to reproduce:
1. Load Mozilla with -console.
2. Load testcase.
3. Type something NOT containing spaces into the first textbox.
4. Hit the button.

   [no error in the console, and the second textbox now has a copy of the text.]

5. Add a space (or several) to the first textbox.
6. Hit the button again.

   [strange error in console, but the second textbox does have a copy of the
   text without spaces.]

Steps 3-4 actually are necessary in order to produce the error message.

JavaScript error:
 line 33: missing } in compound statement

(Most errors like this include a source filename with the line number...)
(Reporter)

Comment 1

18 years ago
Created attachment 17708 [details]
testcase

Comment 2

18 years ago
in bonsai i see timeless checked in a fix at 07:59 10/20/2000, the error output
is specifically mentioned, and it's gone again in build 2000102021. It was bug
53896, now fixed.
(Reporter)

Comment 3

18 years ago
thanks, rkaa. worksforme on 102020 win98.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 4

18 years ago
verifying WFM, since it WFM too.
2000102021 SEA Linux.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.