Double painted text in address bar w/new titlebar & d2d/dwrite

RESOLVED WORKSFORME

Status

()

Core
Graphics
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: jimm, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(blocking2.0 beta2+)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
http://content.screencast.com/users/vvuk/folders/Jing/media/1785139a-fdd7-48c5-a9f0-a3d913a8f197/2010-06-26_1154.png

When changing personas with the new titlebar, the text in the address bar sometimes repaints twice. Possibly an invalidation problem, may already be fixed.
It's actually nothing to do with personas in this case -- that was startup with a fairly new profile (fresh other than the d2d/dw bits), but with d2d and directwrite enabled.  No persona was installed/uninstalled.

It looks like the content is painted 1px stretched, and that just happened to line-double that particular line.  Resizing the window vertically caused it to redraw correctly.
Summary: Double painted text in address bar w/new titlebar & personas switching → Double painted text in address bar w/new titlebar & d2d/dwrite
Likely a d2d issue.
Component: Theme → Graphics
Product: Firefox → Core
QA Contact: theme → thebes
(In reply to comment #1)
> It's actually nothing to do with personas in this case -- that was startup with
> a fairly new profile (fresh other than the d2d/dw bits), but with d2d and
> directwrite enabled.  No persona was installed/uninstalled.
> 
> It looks like the content is painted 1px stretched, and that just happened to
> line-double that particular line.  Resizing the window vertically caused it to
> redraw correctly.

I can't repro this, could you attach a screenshot, Vlad?
(Reporter)

Updated

8 years ago
Bas: see comment 0
blocking2.0: --- → beta2+
(In reply to comment #4)
> Bas: see comment 0

Yeah, found it. Need to find a way to reproduce :s.

Comment 6

8 years ago
Created attachment 455140 [details]
Screenshot

Always good to have attachments in bugzilla
(Reporter)

Comment 7

8 years ago
Is anyone still seeing this? I'm tempted to mark this as resolved WFM.
Does it matter if Cleartype is used by the system or pref'd?
(Reporter)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.