firefox update gets confused when updated by another user

RESOLVED DUPLICATE of bug 685202

Status

()

RESOLVED DUPLICATE of bug 685202
9 years ago
6 years ago

People

(Reporter: amos.shapira, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6 ( .NET CLR 3.5.30729)

I was logged in to Windows Vista while another user was also logged in another session and running Firefox.
Firefox 3.6.4 update was available but trying to execute it failed on "can't restart, make sure there are no other firefox processes around" error. I tried a couple of times until I remembered that it might be running by the other user.
Switched to the other user, there Firefox updated to 3.6.6.
Switched back to my user but now my firefox has "Apply downloaded update now..." which wants to install 3.6.4.
When trying to apply it it restarts firefox pretty quickly (as 3.6.6) but keeps the "apply Downloaded update now..." Help menu item.
This doesn't block me for now but is annoying and I'm not sure what will happen in the next update.


Reproducible: Always

Steps to Reproduce:
1. login to user A and run firefox < 3.6.4
2. switch to user B and run firefox < 3.6.4
3. start download update of 3.6.4
4. click to restart firefox after update install, it will fail to restart firefox (presumably because of the firefox running in the other session).
5. switch to user A and apply the update there, it will update to 3.6.6
6. switch back to user B.
7. Will now have a "Help" menu item "Apply Downloaded Update Now..."
8. Clicking on it will say that it's trying to update to 3.6.4, even though the running version is already 3.6.6

Actual Results:  
"Help" menu item is at "Install Downloaded Update Now..."

Expected Results:  
Help menu item change back to "Check for Updates". Downloaded update should be removed.


Firefox seems to behave correctly besides this.
(Reporter)

Comment 2

9 years ago
As far as I manage to follow the discussion in bug 318855, it appears that it's about a greyed-out help menu item.

In the situation I reported, the menu item is not greyed out but:
1. It tries to "update" to a version which is older than the current version.
2. It fails.
3. It doesn't notice that the update is irrelevant and gets back to the normal state.
The fix for that bug will allow app update to check if there is a second user already downloading an update which will prevent this bug from happening.

Comment 4

7 years ago
This is also annoying when user A does not have update privileges leading to the update never succeeding until I delete the "updates" folder down in app data.

The update should be considered complete when the current version is equal or newer than the version it wants to update to, and then regenerate the updates folder *regardless* of whether the update actually did anything.

I saw that behavior on versions as old as 3.0 and didn't get fixed up to 13.0.1

Comment 5

7 years ago
There are four other submissions for this problem.  See...
  <https://bugzilla.mozilla.org/show_bug.cgi?id=776386>
...for summary.

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 685202
You need to log in before you can comment on or make changes to this bug.