Software Update fails with "The license file for this version could not be found" in

RESOLVED WONTFIX

Status

SeaMonkey
Installer
RESOLVED WONTFIX
8 years ago
7 years ago

People

(Reporter: skierpage, Unassigned)

Tracking

SeaMonkey 2.0 Branch
x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [SmBugEvent])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.9) Gecko/20100317 SeaMonkey/2.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.9) Gecko/20100317 SeaMonkey/2.0.4

I have a long-time Netscape > SeaMonkey 1.x > Seamonkey 2.0. installation.  Help > Check for Updates reported 2.0.5 available.  When I performed the update, I got a Software License Agreement dialog asking me to "Please read the following license agreement".  But the inner frame contained "The license file for this version could not be found. Please visit the SeaMonkey homepage for more information."

Reproducible: Sometimes

Steps to Reproduce:
1. Help > Check for Update when update available.
2. Step through wizard.
Actual Results:  
As above.  The I accept/I do NOT accept radiobuttons and [Accept Terms] are grayed out.

Expected Results:  
Update should work.

I had the same problem with the 2.0 > 2.0.1 update, but other updates worked fine.

Two minor bugs with this error dialog: there should be a link in its text and the text should be selectable for copy and paste.

Note: I *know* the workaround is a fresh installer download!  I'm noting a possible bug in this fine software, not trying to solve my problem.  Can someone tell me the normal path to this license file, other debugging steps, etc?
(Reporter)

Comment 1

8 years ago
I exited the Software Update dialog (but not SeaMonkey 2.0.4) and retried Help > Check for Updates, and this time it worked fine!  It didn't even present a license agreement or prompt me to accept it.

When I filed this bug I had used the back and next buttons in the Software Update wizard, and it failed each time.  And I seemed to have OK network access.  Weird.
Version: unspecified → SeaMonkey 2.0 Branch

Comment 2

8 years ago
Frank, any idea about this one?
Assignee: nobody → installer
Component: General → Installer
QA Contact: general → xpi-packages

Comment 3

8 years ago
See bug 560783 and bug 567840 Specifically Bug 560783 comment 3.
Also see Bug 576939 - Backport app update fixes to 1.9.2 which implies that this is fixed in Gecko 1.9.2 and newer.

Comment 4

7 years ago
Should work in SeaMonkey 2.1. WONTFIX for SeaMonkey 2.0
Whiteboard: [SmBugEvent]

Comment 5

7 years ago
Really resolving.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.