Private Browsing Breaks Navigation (Amongst Others) In New Window

RESOLVED INVALID

Status

()

Firefox
Private Browsing
--
major
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Jamie Kitson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.3a6pre) Gecko/20100627 Minefield/3.7a6pre
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.3a6pre) Gecko/20100627 Minefield/3.7a6pre

If you open a new window while in private browsing mode that window is broken in several ways:

* No navigation available (eg, backwards, forwards)
* URL in address bar does not change as you navigate
* Stop Private Browsing not available
* Window/browser has to be closed and reopened twice before normal browsing is returned

Reproducible: Always

Steps to Reproduce:
1. Go Tools -> Start Private Browsing
2. Open a new window
3. Optionally close the old window
Actual Results:  
Navigation and Stop Private Browsing is broken.

Expected Results:  
Standard behaviour.

Comment 1

7 years ago
Do you get anything logged to the error console when you enter the private browsing mode?  Also, do you get anything logged to the error console when you open a new window after entering the private browsing mode?

Additionally, can you try running Firefox with a new profile and seeing if you see the same behavior?
(Reporter)

Comment 2

7 years ago
No errors when I enter private browsing, but this is what I get when I then open a new window:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIObserverService.addObserver]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: chrome://browser/content/browser.js :: prepareForStartup :: line 4245"  data: no]

Error: aBrowser is undefined
Source File: file:///home/jamie/downloads/3.7/firefox/components/nsSessionStore.js
Line: 754

If I use a new profile the error does not happen.

Comment 3

7 years ago
The failure is probably caused by this line:

<http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser.js#1190>

Which doesn't make a lot of sense to me.

Do you have any extensions installed?
(Reporter)

Comment 4

7 years ago
Ok, it seems to be caused by the Ubuntu plugin. I didn't think that any of my plugins were compatible with 3.7.
(Reporter)

Comment 5

7 years ago
It also causes the following error on alternate start ups, which causes my previous tabs not to load, ie, I shut and reopen firefox and no tabs are loaded, I shut and restart it and my previous tabs load.
(Reporter)

Comment 6

7 years ago
I've reported this on launchpad:

https://bugs.launchpad.net/ubuntu/+source/ubufox/+bug/599662

Comment 7

7 years ago
Thanks a lot!

Resolving as INVALID since this is not a bug in our code.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Reporter)

Comment 8

7 years ago
Surely a plugin shouldn't be allowed to cause this issue though?

Comment 9

7 years ago
Extensions can break things in many different ways!  They can do almost anything to the browser!
(Reporter)

Comment 10

7 years ago
Good point.
You need to log in before you can comment on or make changes to this bug.