If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

XPCOM stack walker on Windows should print library+offset

RESOLVED FIXED

Status

()

Core
XPCOM
RESOLVED FIXED
7 years ago
5 years ago

People

(Reporter: Jesse Ruderman, Assigned: ted)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
When a Windows build has insufficient symbols, the XPCOM stack walker should print library+offset rather than badsym+offset.  Preferably in the same format that Mac and Linux use.

I'd accept both (e.g. library+offset + badsym+offset) if it's hard to detect whether the symbols available to the stack walker are "insufficient".

This would allow Windows Tinderbox tests to use fix_stack_using_bpsyms.py and get decent stack traces.
(Reporter)

Comment 1

7 years ago
Created attachment 454450 [details]
example of bad output on tinderbox
(Reporter)

Comment 2

7 years ago
Created attachment 454451 [details]
example of good output from a local debug build

The Windows stack walker actually works really well on non-stripped builds.  It's only stripped builds that would benefit from this change.
(Reporter)

Comment 3

7 years ago
Fixing this might be as simple as grabbing aDetails->loffset in NS_FormatCodeAddressDetails.  But I get disoriented by all the ifdefs in nsStackWalk.cpp.
Fixing this would help debug assertions that are only seen on tinderbox.  I've got a few right now that I can't reproduce locally, and are windows only :(

Updated

7 years ago
Blocks: 599969
In fact, I'd say that it's preventing me from fixing bug 599969 (blocker).
blocking2.0: --- → ?

Updated

7 years ago
No longer blocks: 599969

Updated

7 years ago
Blocks: 612617
Blocking, since it blocks a blocker.
blocking2.0: ? → beta9+
Don't need this for bug 612617 anymore.
No longer blocks: 612617
blocking2.0: beta9+ → ?

Updated

7 years ago
blocking2.0: ? → -
See Also: → bug 751673
(Reporter)

Comment 8

5 years ago
Fixed by Ted as part of his patch in bug 751673.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
I kinda forgot there was a bug on this.
Assignee: nobody → ted
Depends on: 751673
You need to log in before you can comment on or make changes to this bug.