[adbe 2655193] Flash needs to block certain old nvidia graphics drivers to avoid crashing [@ nvapi.dll@0x4683e ] [@ nvapi.dll@0x4e97e ] on Flash videos

RESOLVED WORKSFORME

Status

defect
--
critical
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: bp9382, Assigned: timeless)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [FIXED nvidia Quadro 7.19.2010], crash signature, )

Attachments

(1 attachment)

36.13 KB, text/plain
Details
Reporter

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
Build Identifier: Mozilla Firefox 3.6.6

Flash 10.1 works with IE. 
Tried changing the timeout value as per the "help" article. Ineffective.
Let me know when you fix the compatibility with Flash. I can't use firefox until you do. 

Reproducible: Always

Steps to Reproduce:
1.go to youtube.com using firefox
2. attempt to play video
3. bask in the fail glow
Actual Results:  
plugin crash notice.

Expected Results:  
Video playing.

Internet Explorer works fine with the newest version of flash. Hint hint.
Flash for IE is Active X and Flash for all other browsers is NPAPI, comparing them is useless.

>plugin crash notice.
Please post the crash ID https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report
If you go to abou:plugins, is flash listed?
Reporter

Comment 3

9 years ago
Of course it is listed. I would'nt complain about it not working if I hadn't installed it. 

I have also run through all troubleshooting listed on the "help" page, uninstalling + re-installing, plus configuration changes.

If it helps, flash on most web content works, it is video and high motion flash pages (such as the submit prediction page @ www.ufc.com) that crash.
Reporter

Comment 5

9 years ago
Yes. The problem persists.
Again, please post a crash ID.
Reporter

Comment 7

9 years ago
1389b51d-c510-4200-9d74-3c1a8ade5adc
57f07e5e-9700-4276-800c-eba660b3b844
Neither of those worked for me. Please post all that you have.
Reporter

Comment 9

9 years ago
bp-9ed67c58-c0dc-4c0a-82f0-14b002100629	6/29/2010	2:44 PM
9beb24fd-13d0-473e-925a-a4f89aaefa80	6/29/2010	7:33 AM
cbbe8a70-dafa-4951-8c46-8b5820185f8f	6/28/2010	11:23 AM
ea21bea6-a5c1-46d3-a222-bad1a613a819	6/28/2010	11:23 AM
cf2e1354-68f5-4389-8e5e-5e3f1e367f5c	6/28/2010	11:14 AM
d4470794-6b40-4b84-a899-2b4ae7955597	6/28/2010	11:14 AM
bp-71367212-9959-4b07-b430-f67e32100628	6/28/2010	10:38 AM
bp-932bc167-67b9-4e4b-aadf-57db02100628	6/28/2010	10:01 AM
bp-7ed5271a-e3d9-4f05-bded-c8f592100628	6/28/2010	9:53 AM
bp-ceab0621-1200-481d-9ad4-cc9e82100628	6/28/2010	9:43 AM
bp-46553adb-1915-45f1-ab98-a6d512100628	6/28/2010	9:40 AM
c4951820-3513-4830-97d5-7cd1f293e63e	6/28/2010	8:19 AM
bp-055f730e-9951-4b7d-b062-c0d102100628	6/28/2010	8:18 AM
bp-aef4ea83-784d-4eda-b730-3e54d2100628	6/28/2010	8:18 AM
bp-07755717-21c4-4eba-81a0-642c82100628	6/28/2010	8:18 AM
e2856190-5028-45d0-90d7-d779058ea4ba	6/24/2010	4:39 PM
a36e0e75-cff6-4656-8174-f09b9a369dd7	6/24/2010	4:25 PM
b40b6d9e-3db8-4c89-bd29-66d6527ca44a	6/24/2010	4:24 PM
bc285f20-d947-4f94-bc97-92898e8f141e	6/24/2010	4:18 PM
bp-4a81fdcc-6cbc-4c52-a5f0-c19542100624	6/24/2010	4:17 PM
ef785120-e3e0-44cc-baaa-27cbf8ad2379	6/24/2010	10:56 AM
96e5da79-6861-46e0-9422-31c9fd925f55	6/24/2010	10:56 AM
9d16b95d-4a1c-432a-be8f-690d763d80ef	6/24/2010	10:56 AM
0429f59e-ab16-4f75-b825-24f3cc7e44ca	6/24/2010	10:55 AM
1e25f8f3-63d4-4ea8-98df-52c4c5a40c9e	6/24/2010	10:54 AM
5ae36ea5-0587-4c7e-8feb-34655a87d427	6/24/2010	10:53 AM
4709ecc9-7e2d-404b-9b81-b493530d3d2a	6/24/2010	10:48 AM
483eedd0-2a7e-4821-939f-c9a5ef0974f9	6/24/2010	10:37 AM
139b1959-5c48-44a9-b6cc-563e4367c0bf	6/24/2010	10:34 AM
1afd8bea-ecaf-41dd-9d06-8d43953519ea	6/24/2010	10:29 AM
97df508a-e7d2-4ccc-aad4-4c9865f37270	6/24/2010	10:29 AM
cf8ae828-0caf-4b72-9144-1c6bd83bc24e	6/24/2010	10:29 AM
d16f43b1-ac6a-4a34-88dd-9b4491e70111	6/24/2010	10:26 AM
b588764e-43e7-4172-bf43-ad3044cfed20	6/24/2010	10:21 AM
bp-17bc8070-5d4f-47f3-b536-d92b52100624	6/24/2010	10:20 AM
The flash plugin crashes in the nvidia graphic card driver. I don't know why the ActiveX plugin crashes in the same way but that doesn't matter for us.


0  	nvapi.dll  	nvapi.dll@0x4683e  	
1 		@0x30002ff 	
2 	NPSWF32.dll 	F1816262520_______________________________________________ 	F_2065755532_____________________________________________:5909
Component: General → Flash (Adobe)
Product: Firefox → Plugins
QA Contact: general → adobe-flash

Comment 11

9 years ago
can you attach the information when executing dxdiag?

1. open a command prompt: Start>Run... 
2. type: cmd <enter>
3. type: dxdiag <enter>
4. Select the [Save All information] button and attach it to this bug
Reporter

Comment 12

9 years ago
Posted file direct x

Comment 13

9 years ago
thanks bp9382.  entered an internal bug with the dxdiag info.

Updated

9 years ago
Assignee: nobody → smadayag
Reporter

Comment 14

9 years ago
Any fix as of yet? Suggested action?

Comment 15

9 years ago
@bp9382 - the bug is still under review and no other information is available.  would you mind to upgrade your video driver?

http://www.nvidia.com/object/quadro-winxp-x32-258.96-whql-driver.html

this is the latest release 7.19.2010.
Summary: Firefox 3.6 (.4, .6) not compatible with Flash 10, 10.1 → Crash [@ nvapi.dll@0x4683e ] [@ nvapi.dll@0x4e97e ] on Flash videos with certain nvidia graphics drivers
Status: UNCONFIRMED → NEW
Ever confirmed: true
Severity: major → critical
Summary: Crash [@ nvapi.dll@0x4683e ] [@ nvapi.dll@0x4e97e ] on Flash videos with certain nvidia graphics drivers → Flash plugin crash [@ nvapi.dll@0x4683e ] [@ nvapi.dll@0x4e97e ] on Flash videos with certain nvidia graphics drivers
Assignee

Updated

9 years ago
Keywords: crash
Assignee

Comment 16

9 years ago
smadayag: btodur@nvidia.com has expressed some interest in helping from the nvidia side.

FWIW this is the 3rd most popular nvidia crash (116 crashes w/in the past week for nvapi.dll@0x4e97e -- nvapi.dll@0x4683e is the 10th most popular with 41 crashes.)

Comment 17

9 years ago
I dont see any crash dumps with the latest driver. Can someone list the driver version with the nvapi.dll crash address.

Please try with the 258.96 driver for the repro.

Thanks
Assignee

Comment 18

9 years ago
smadayag/todur: if this is only a problem w/ the older driver, what would happen if we prevented the old library from loading, would flash still work? we do have provisions to block libraries w/ versions less than <x> from loading, and as this seems to be a popular crash, I think it's worth considering.

Comment 19

9 years ago
My preference would be to block a specific driver version directly in Flash to ensure we fix this issue for all scenarios. We already have filtering logic to do this, should this turn out to be Bipin's guidance. (We can pursue both options if this accelerates a fix, but I don't know how Flash will behave if the load is blocked.)

End users can also temporarily disable hardware acceleration in Flash until a fix is available.
Assignee

Comment 20

9 years ago
reporter, could you please install the driver from:
http://www.nvidia.com/object/quadro-winxp-x32-259.12-whql-driver.html
Reporter

Comment 21

9 years ago
new driver fixes issue. thx
Assignee

Comment 22

9 years ago
nvapi.dll	6.14.11.9062	6E831E9F66AD4DD7BC1E0788CBEC310C1	nvapi.pdb
OS: Windows XP → All
Assignee

Updated

9 years ago
Depends on: 585973
Assignee

Comment 23

9 years ago
Filed bug 585973 for our side of blocklisting

Resolving as WORKSFORME for the time being per comment 21.

Explanation: WORKSFORME because the fix wasn't in Flash code.

This could be changed to FIXED when either of the following occur:
* Flash starts blocking this version
* We create a component for Nvidia -- no current eta, although I'm hoping to propose such a thing for 2011
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Whiteboard: [FIXED nvidia Quadro 7.19.2010]

Comment 24

9 years ago
added the notes to our internal bug.  no eta, but it will be resolved in a future release.
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Resolution: WORKSFORME → ---
Assignee

Updated

9 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Summary: Flash plugin crash [@ nvapi.dll@0x4683e ] [@ nvapi.dll@0x4e97e ] on Flash videos with certain nvidia graphics drivers → Flash needs to block certain old nvidia graphics drivers to avoid crashing [@ nvapi.dll@0x4683e ] [@ nvapi.dll@0x4e97e ] on Flash videos

Updated

9 years ago
Summary: Flash needs to block certain old nvidia graphics drivers to avoid crashing [@ nvapi.dll@0x4683e ] [@ nvapi.dll@0x4e97e ] on Flash videos → [adbe 2655193] Flash needs to block certain old nvidia graphics drivers to avoid crashing [@ nvapi.dll@0x4683e ] [@ nvapi.dll@0x4e97e ] on Flash videos

Comment 25

9 years ago
A note from our developer:  It crashes before we can even get to the driver gating logic, at GetDeviceCaps....  nothing we can do Flash side about driver gating.
Assignee: smadayag → timeless
Assignee

Comment 26

9 years ago
ok, going back to worksforme "newer driver fixed this", since per comment 25 there's nothing flash can do -- thanks for the followup.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ nvapi.dll@0x4683e ] [@ nvapi.dll@0x4e97e ]
You need to log in before you can comment on or make changes to this bug.