Closed Bug 575446 Opened 10 years ago Closed 10 years ago

Hang and too-much-recursion crash with tree, filter, text-shadow

Categories

(Core :: XUL, defect, critical)

x86
macOS
defect
Not set
critical

Tracking

()

RESOLVED FIXED

People

(Reporter: jruderman, Assigned: neil)

References

(Blocks 2 open bugs)

Details

(Keywords: crash, hang, testcase)

Attachments

(2 files)

No description provided.
After it hangs for a while, it hits a too-much-recursion crash:

...
477  PresShell::HandlePostedReflowCallbacks(int) + 225 (nsPresShell.cpp:4685)
478  PresShell::DidDoReflow(int) + 38 (nsPresShell.cpp:7301)
479  PresShell::ProcessReflowCommands(int) + 503 (nsPresShell.cpp:7569)
480  PresShell::FlushPendingNotifications(mozFlushType) + 840 (nsPresShell.cpp:4816)
481  PresShell::HandlePostedReflowCallbacks(int) + 225 (nsPresShell.cpp:4685)
...
Keywords: crash
Summary: Hang with tree, filter, text-shadow → Hang and too-much-recursion crash with tree, filter, text-shadow
Bug 550306 shows a similar too-much-recursion pattern.
What seems to be going on here is that the tree is trying to mediate the wrong scrollbar - it's finding the scrollbar caused by making the <tree> element overflow: scroll, instead of the XBL scrollbar element. So it keeps on trying to set the maxpos to 0 (since the tree body isn't scrollable) while the overflow: scroll frame tries to set the maxpos to 454526, which appears to be the number of CSS pixels of overflow caused by the outline.
Attached patch Proposed patchSplinter Review
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #454811 - Flags: review?(enndeakin)
Attachment #454811 - Flags: review?(enndeakin) → review+
Pushed changeset 4a12cdb66595 to mozilla-central.
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.