Closed Bug 575509 Opened 9 years ago Closed 9 years ago

Port |Bug 516758 - Remove more options from configure| to comm-central

Categories

(MailNews Core :: Build Config, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.3a1

People

(Reporter: t.matsuu, Assigned: t.matsuu)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; ja; rv:2.0b2pre) Gecko/20100629 Fedora/4.0b2pre-0.b2pre.2010062914.fc13 Minefield/3.7a6pre Firefox/3.6.4
Build Identifier: 

As per bug 516758 comment #39.

Reproducible: Always
Blocks: C192ConfSync
(In reply to bug 516758 comment #39)
> (From update of attachment 454457 [details] [diff] [review])
> >+dnl ========================================================
> > dnl = Enable help viewer (off by default)
> > dnl ========================================================
> 
> Please keep this option intact as far as c-c has it. It was only retained in
> _any_ form in m-c because c-c actually uses it. My reasoning -- We should allow
> SeaMonkey to build without this (--disable-*) though it has little use for
> Thunderbird.

"MOZ_HELP_VIEWER=1" is explicitly set at suite/confvars.sh now, so I suppose help viewer is still enabled in SeaMonkey and we can remove this option from configure script.
Attachment #454776 - Flags: review?(bugspam.Callek)
OS: Linux → All
Hardware: x86 → All
Attachment #454776 - Flags: review?(bugspam.Callek) → review+
(In reply to comment #1)
> Created an attachment (id=454776) [details]
> Just copy from attachment 454457 [details] [diff] [review].
> 
> (In reply to bug 516758 comment #39)
> > (From update of attachment 454457 [details] [diff] [review] [details])
> > >+dnl ========================================================
> > > dnl = Enable help viewer (off by default)
> > > dnl ========================================================
> > 
> > Please keep this option intact as far as c-c has it. It was only retained in
> > _any_ form in m-c because c-c actually uses it. My reasoning -- We should allow
> > SeaMonkey to build without this (--disable-*) though it has little use for
> > Thunderbird.
> 
> "MOZ_HELP_VIEWER=1" is explicitly set at suite/confvars.sh now, so I suppose
> help viewer is still enabled in SeaMonkey and we can remove this option from
> configure script.

Actually thinking about it more, even if we did keep the --enable/disable choice _here_ it would not affect things anyway, since m-c would still only read from our confvars.sh. Given that, r+
Status: UNCONFIRMED → NEW
Ever confirmed: true
Thanks.
Keywords: checkin-needed
Whiteboard: [c-n c-c]
Depends on: 516758
Assignee: nobody → t.matsuu
Checked in: http://hg.mozilla.org/comm-central/rev/a8edda118d97
Status: NEW → RESOLVED
Closed: 9 years ago
Flags: in-testsuite-
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [c-n c-c]
Target Milestone: --- → Thunderbird 3.2a1
Blocks: 546177
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.