Closed Bug 575556 Opened 11 years ago Closed 11 years ago

Cannot upload photo from device

Categories

(Firefox for Android Graveyard :: General, defect)

x86
Linux
defect
Not set
normal

Tracking

(fennec2.0b1+)

VERIFIED FIXED
Tracking Status
fennec 2.0b1+ ---

People

(Reporter: vladmaniac, Assigned: azakai)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a6pre) Gecko/20100628 Minefield/3.7a6pre
Build Identifier: 20100628041239

Cannot upload photo from Nokia N900 [Maemo5]. File is selected successfully from file manager but does not appear on site's upload bar. 

Reproducible: Always

Steps to Reproduce:
1.Navigate to http://www.imageshack.com/
2.Upload a photo from device. 

Actual Results:  
File selected for upload does not appear on upload bar. 

Expected Results:  
The file picker should show up on your screen when selecting the "Browse..." . You should be able to access your filesystem as well.
The photo should show up on your browser window.
I'm able to see the filepicker on builds:

Mozilla/5.0 (X11; U; Linux armv71; Nokia N900; en-US; rv:2.0b2pre) Gecko/2010630 Namoroka/4.0b2pre Fennec/2.0a1pre


and

Mozilla/5.0 (X11; U; Linux armv71; Nokia N900; en-US; rv:2.0b2pre) Gecko/2010630 Namoroka/4.0b2pre Fennec/2.0a1pre (latest-electrolysis-maemo5-gtk)
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
Actually, I'm seeing this on build:

Mozilla/5.0 (X11; U; Linux armv71; Nokia N900; en-US; rv:2.0b4pre) Gecko/20100812 Namoroka/4.0b4pre Fennec/2.0a1pre

and

Mozilla/5.0 (Android; U; Linux armv71; en-US; rv:2.0b4pre) Gecko/20100812 Namoroka/4.0b4pre Fennec/2.0a1pre
Status: RESOLVED → REOPENED
tracking-fennec: --- → ?
Ever confirmed: true
Resolution: WORKSFORME → ---
I confirm that on both builds
tracking-fennec: ? → 2.0b2+
Found it. This is broken for e10s because the nsIContentPrefService needs to be
e10s-ified (see bug 584842).

This code fails:
http://mxr.mozilla.org/mozilla-central/source/layout/forms/nsFileControlFrame.cpp#681

Because StoreLastUsedDirectory tries to use nsIContentPrefService and fails:
http://mxr.mozilla.org/mozilla-central/source/layout/forms/nsFileControlFrame.cpp#807
Depends on: 584842
Duplicate of this bug: 588556
hey mark, is this really a blocking beta 2 bug?   We have this testcase as one of our defined smoketests that should at least pass alpha 1, much less beta 1.  

If you dont feel its that important for beta 1 quality at the very least, we'll move this test into our BFTs.   

Thanks,
Tony
I'm worried that we won't have the "ideal" fix for beta 1. Maybe we could make a "less than ideal" fix for beta 1?

When I suggested that, others frowned upon the "less than ideal" fix. Let's see what happens.
tracking-fennec: 2.0b2+ → 2.0b1+
The patches in bug 584842 should fix this. Can someone please test to see if they work on a device? (Testing on desktop doesn't seem to work - should it?)
Assignee: nobody → azakai
Desktop is broken too. the fix should work there too.
(In reply to comment #9)
> Desktop is broken too. the fix should work there too.

I can't even get a file dialog on desktop, so I can't test this there.

Should file dialogs work? I'm on Qt, is that perhaps the issue?
(In reply to comment #10)
> (In reply to comment #9)
> > Desktop is broken too. the fix should work there too.
> 
> I can't even get a file dialog on desktop, so I can't test this there.
> 
> Should file dialogs work? I'm on Qt, is that perhaps the issue?

Works on Gtk. I remember seeing a bug on the Qt build.
(In reply to comment #11)
> Works on Gtk. I remember seeing a bug on the Qt build.

Thanks for the info.

Ok, built on GTK, tested the patch - hooray, it works.
Blocks: 584225
I am getting funny default path with the test URL here, file picker on N900 gives me user/Desktop which actually should not exist. Tested with Fennec nightly 20100831.
Hi alon, how close are we getting a patch on this up?   Per my comment 6, we want to have this working again so our smoketests are passing.  I assume beta 1 is on the scope?
There is a patch for this that works. It however is waiting on bug 592017, through a few other bugs (all with patches).

I am trying to find out from smaug when bug 592017 is expected, but do not have an answer yet.
we landed the requirements to fix this (without bug 592017 which we can do later). This should be fixed up.
Status: REOPENED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → FIXED
Patch had to be backed out due to OS X ipc test issues.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Flags: in-litmus+
relanded.
Status: REOPENED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → FIXED
verified FIXED on builds:

Mozilla/5.0 (X11; U; Linux armv71; Nokia N900; en-US; rv:2.0b6pre) Gecko/20100909 Namoroka/4.0b6pre Fennec/2.0b1pre

Followup bug https://bugzilla.mozilla.org/show_bug.cgi?id=595025 for osx and android file picker is still broken.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.