JM: Pressing enter in location bar/search bar has no effect

RESOLVED FIXED

Status

()

Core
JavaScript Engine
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: dmandelin, Assigned: dmandelin)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

8 years ago
The problem is that in autocomplete.xml, the variable mController doesn't get set. It is set in a constructor function like this:

  mController = blah

with no |this|. This works (in m-c) because it is called with JS_CallFunctionValue with a scope chain of the XULElement that has mController defined.

In JM, we are getting a JSOP_SETGNAME for that, which is wrong--that should only be used in comple-and-go mode.
(Assignee)

Comment 1

8 years ago
http://hg.mozilla.org/users/danderson_mozilla.com/moo/rev/fcc3814a3c01
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.