Quakelive breaks aero theme

RESOLVED DUPLICATE of bug 545892

Status

()

RESOLVED DUPLICATE of bug 545892
8 years ago
8 years ago

People

(Reporter: matjk7, Unassigned)

Tracking

Trunk
All
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:2.0b2pre) Gecko/20100630 Minefield/4.0b2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:2.0b2pre) Gecko/20100630 Minefield/4.0b2pre

When quitting quakelive, aero glass no longer works on the browser, firefox button is gone and text (in the titlebar) sometimes appears weird too. 

Reproducible: Sometimes

Steps to Reproduce:
1.Register on quakelive.com and download the plugin
2.Play a game and then quit
Actual Results:  
Aero glass was broken and firefox button was gone.

Expected Results:  
Theme and titlebar should behave normally.

Its not always reproducible for some reason, but it happens most of the time. Not sure if this is a regression from drawing in the titlebar for windows. The minimize/resize/close buttons stop working when this happens as well.
(Reporter)

Comment 1

8 years ago
Created attachment 455341 [details]
Screenshot after quitting quakelive.
(Reporter)

Updated

8 years ago
Blocks: 513162
blocking2.0: --- → ?
Version: unspecified → Trunk
Were you using D2D/DW also?  I see this occasionally, but not necessarily with a particular website, but it switches down.  Typically desktop composition is disabled is what seems to be happening.
It might be that letting windows 7 manage visual performance settings itself does it.
(Reporter)

Comment 4

8 years ago
Happens with d2d/dw off as well, and I'm not sure windows 7 would need to do that (or even if I have that option enabled, I've been using win7 for like 1 month at most so I'm still quite unfamiliar with the options) since I have a fairly decent PC (c2d e8400@3ghz, 2gb ram, nvidia 9800gt gpu) and quakelive isnt that hardware demanding.

Comment 5

8 years ago
This happens with some Flash apps too. Basically, if the Flash hangs a bit, aero is disabled. This is bothersome, so I just disable **** Flash. Of course, that's not an option for most users.
(In reply to comment #5)
> This happens with some Flash apps too. Basically, if the Flash hangs a bit,
> aero is disabled. This is bothersome, so I just disable crappy Flash. Of
> course, that's not an option for most users.

I can confirm I also see it happen with WMP plugin using TV-Fox extension, sometimes it disables aero glass.
(Reporter)

Comment 7

8 years ago
Ok so it seems other people experience the same problem but only with other plugins, so I disabled OOPP and now I cant reproduce the bug, can anyone confirm this?

Comment 8

8 years ago
I can confirm that if I disable Flash I can't reproduce the problems, that's what I can confirm.

I can also confirm that if I disable Firefox, I can't reproduce them either.

Comment 9

8 years ago
The Quake plugin isn't out of process, by the way.
(Reporter)

Comment 10

8 years ago
It isnt out-of-process in the 3.6.x branch, but any plugin is out-of-process in current minefield.

Comment 11

8 years ago
(In reply to comment #5)
> This happens with some Flash apps too. Basically, if the Flash hangs a bit,
> aero is disabled. This is bothersome, so I just disable crappy Flash. Of
> course, that's not an option for most users.

(In reply to comment #7)
> Ok so it seems other people experience the same problem but only with other
> plugins, so I disabled OOPP and now I cant reproduce the bug, can anyone
> confirm this?

Possibly bug 576168? I think the Quake Live thing with the tabs bar might be  different.

Comment 12

8 years ago
(In reply to comment #11)
> (In reply to comment #5)
> > This happens with some Flash apps too. Basically, if the Flash hangs a bit,
> > aero is disabled. This is bothersome, so I just disable crappy Flash. Of
> > course, that's not an option for most users.
> 
> (In reply to comment #7)
> > Ok so it seems other people experience the same problem but only with other
> > plugins, so I disabled OOPP and now I cant reproduce the bug, can anyone
> > confirm this?
> 
> Possibly bug 576168? I think the Quake Live thing with the tabs bar might be 
> different.

Woops, bug 545892 - "[OOPP] Plugins kill aero glass / browser window sometimes looses aero glass effect."
(Reporter)

Comment 13

8 years ago
(In reply to comment #12)
> (In reply to comment #11)
> > (In reply to comment #5)
> > > This happens with some Flash apps too. Basically, if the Flash hangs a bit,
> > > aero is disabled. This is bothersome, so I just disable crappy Flash. Of
> > > course, that's not an option for most users.
> > 
> > (In reply to comment #7)
> > > Ok so it seems other people experience the same problem but only with other
> > > plugins, so I disabled OOPP and now I cant reproduce the bug, can anyone
> > > confirm this?
> > 
> > Possibly bug 576168? I think the Quake Live thing with the tabs bar might be 
> > different.
> 
> Woops, bug 545892 - "[OOPP] Plugins kill aero glass / browser window sometimes
> looses aero glass effect."

Looks like it is the same bug indeed, should I mark this as duplicate?
Looks like a dupe to me, yes, I would mark it dupe.

Comment 15

8 years ago
Dupes of bug 545892 - "OOPP kills aero", and potentially "plugin shows up in glass" clipping problem we have (bug 574957).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 545892
blocking2.0: ? → ---
You need to log in before you can comment on or make changes to this bug.