Tables obscured by their own margins after style change

VERIFIED DUPLICATE of bug 86314

Status

()

P3
normal
VERIFIED DUPLICATE of bug 86314
18 years ago
10 years ago

People

(Reporter: jwbaker, Assigned: karnaze)

Tracking

({css2, dom2, testcase})

Trunk
css2, dom2, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
This bug is hard to explain, so please use the attached testcase.  The table has
two cells.  One of the cells initially has "display: none".  After clicking on
the visible cell, the second cell is changed to "display: table-cell".  When
this happens, the tables margins are miscalculated such that the left side of
the table is obscured.

Again, please use the testcase for a more clear demonstration.
(Reporter)

Comment 1

18 years ago
Created attachment 17746 [details]
Testcase
(Reporter)

Updated

18 years ago
Keywords: css2
Good catch!

This is an incremental repaint problem. When the display property changes, we
are not repainting the area to the left of the original left of the table (the
table moves because it is centered).
Component: HTMLTables → DOM Level 2
Keywords: correctness, testcase
OS: Linux → All
QA Contact: chrisd → ian
Hardware: PC → All
Keywords: dom2
Component: DOM Level 2 → DOM HTML
QA Contact: ian → amar
(Assignee)

Comment 3

17 years ago

*** This bug has been marked as a duplicate of 86314 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
verified dupe
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: DOM: HTML → DOM: Core & HTML
QA Contact: amar → general
You need to log in before you can comment on or make changes to this bug.