AOM gives no notification of failed updates and just loses extensions

VERIFIED DUPLICATE of bug 587088

Status

()

VERIFIED DUPLICATE of bug 587088
9 years ago
8 years ago

People

(Reporter: pwd.mozilla, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [AddonsRewrite])

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:2.0b2pre) Gecko/20100630 Minefield/4.0b2pre
Build Identifier: 

For updates that fail like Firefox Sync regularly does, you have no idea, unless you check your AOM list. There should be some sort of notification and ability to retry.

Reproducible: Always
(Reporter)

Updated

9 years ago
Blocks: 550048
So what do you mean with "just loses extensions". If that's another issue please file it as a separate bug.

Which version of Firefox Sync you have tried to update? Please give us some more information.
Whiteboard: [AddonsRewrite]
Version: unspecified → Trunk
(Reporter)

Comment 2

9 years ago
I just attempted to update to 1.4 (checked website for this as the AOM doesn't inform of this) via the "Update Add-Ons" links and it downloaded the updated. I clicked restart and when I checked the AOM again, Sync was missing from the extension list. This isn't the first time it's happened and it's not the only extension it happens with, though it's a very regular occurrence for Sync. Sync just wasn't in the extension list.
Can you please also tell us which version you had before and from which location/url you have installed the xpi?
(Reporter)

Comment 4

9 years ago
I was using 1.3 (maybe it might've been 1.3.1, I can't recall exactly). I originally installed that from the Labs/Weave site and due to being lost before, I had reinstalled from the AMO site.

After I attempted to reinstall from the AMO site after losing the extension it never worked and I got no notification of failure. Due to having some experience with this before, I restarted my laptop and then went back to the AMO site, clicked install and it installed.
I have installed Firefox Sync v1.4 from AMO and the update was applied without any error. Do you still have the download URL from the Mozilla Labs website? I would need it to get more information which is wrong with those updates.

Tony or Tracy, you know of those older download urls? Are those still existent?
(Reporter)

Comment 6

9 years ago
https://mozillalabs.com/sync/

I might suggest trying to go back a few versions and upgrading.
All those posts of new versions of Firefox Sync link to AMO for the XPI. I can't reproduce your scenario with Sync. If you can, please tell us which version makes problems.

Dave, for the general case of update failures, do we already have a set of error messages in-place somewhere for the new add-ons manager, or is it something we have to implement? I wonder about the usefulness of this bug report.
All of the updates UI is waiting on bug 562622
(Reporter)

Comment 9

9 years ago
Sync just disappeared again. It's not displayed in the AOM after latest manual (clicked check for updates) update.
(In reply to comment #9)
> Sync just disappeared again. It's not displayed in the AOM after latest manual
> (clicked check for updates) update.

Can you attach a copy of extensions.log from your profile folder if it exists.
(Reporter)

Comment 11

9 years ago
Created attachment 461243 [details]
Extensions.log

As requested
(Reporter)

Updated

9 years ago
Attachment #461243 - Attachment mime type: application/octet-stream → text/plain
Looks like this could be related to bug 582837 however there are also some errors suggesting the Firefox is unable to remove the extension directory containing Sync. Not sure what would cause that at the moment.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 587088
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.