Feature request, show non-standard HTML errors in new window

VERIFIED DUPLICATE of bug 6211

Status

SeaMonkey
General
P3
major
VERIFIED DUPLICATE of bug 6211
18 years ago
14 years ago

People

(Reporter: tony.haglof, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)
BuildID:    20001018-09


Since Mozilla will be supporting only the real HTML standard specifications, 
maybe it would be a great idea to have an option like "Show Non-standard HTML 
errors" that you could toggle ON/OFF in the menu or preferences.

When the option is turned on it should display a window presenting the tags 
that are not supported in the page, with a little explanation and maybe a link 
to W3.ORG.

For example when displaying pages with Netscape layers or 
like "http://home.passagen.se/elr/sommar.html" that uses the 
unsupported "leftmargin" tag, A new windows appears:

"This page uses an unsupported tag "Leftmargin" that is Microsoft propritary 
and it is not supported in the HTML specifikation. This could result that this 
page displays incorrectly."


Reproducible: Always
Steps to Reproduce:
1. Use Mozilla on a page enhanced for IE or Netscape (propritary tags)
2.
3.

Expected Results:  Display an optional window that tells the user that there is 
a problem with the HTML coding.



A lot of people trying out Mozilla or Netscape6 tells me that some pages 
renders things wrong and that the same pages works in Internet 
Explorer/Netscape communicator.

For example pages using layers and leftmargin...

An explanation of the non-standard HTML would really help them understand why 
and when a page is displayed wrong and that Mozilla is not "buggy".
(Assignee)

Comment 1

18 years ago
I think that this is a duplicate.  I will try to find the original report.

Comment 2

18 years ago
dupe of

*** This bug has been marked as a duplicate of 47108 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
This is actually a dup of bug 6211, which wants Mozilla to show all errors with 
the html of a page, or at least warn the user when quirks present in Netscape 4 
are used (whether the quirks are still present or not).  Bug 47108 is mostly 
about the status bar display.

Comment 4

18 years ago
eeek, jesse is right. reopneing to do thus
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 5

18 years ago
dupe of 6211


*** This bug has been marked as a duplicate of 6211 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE
vrfy
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.