"Save as" comand causes delay (~1 minute) with message "C:Program%20Files/Mozilla%20Firefox/modules/XPCOMUtils.jsm:165"

RESOLVED INCOMPLETE

Status

()

Firefox
File Handling
--
major
RESOLVED INCOMPLETE
8 years ago
7 years ago

People

(Reporter: Mausebaer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6

If a picture or a different downloaded object (also websites to be stored) is tried to save using the "save as" option, a longer delay occurs (in my case about one minute) until a message is shown "C:Program%20Files/Mozilla%20Firefox/modules/XPCOMUtils.jsm:165" or similar.
After confirmation that the unresponsive script has to be executed, the script ends successfully.

This strange behaviour happens just ONCE per firefox session, all subsequent saves are carried out immediately errorless.

This behaviour occurs since FF3.0, not with former versions


Reproducible: Always

Steps to Reproduce:
1.Start Firefox
2.Choose any object to be saved
3.Choose "Save as"

Actual Results:  
Delay of ~1 minute (screen freezes)

Expected Results:  
Message unresponsive script "C:Program%20Files/Mozilla%20Firefox/modules/XPCOMUtils.jsm:165"
should script be stopped or not

Sometimes (maybe in one case of 30) the script runs through the first time without message....

Tried already to install FF new, without addons resp. in safe mode, nothing helped

See URL above for other users having the same problem.
(Reporter)

Comment 1

8 years ago
As I'm using the german FF version, I do not know how exactly the message is in english...
In any case the script message
"Skript: file:///C:Program%20Files/Mozilla%20Firefox/modules/XPCOMUtils.jsm:165"
is identical.
(Reporter)

Comment 2

8 years ago
Disabling "Mozilla Default Plugin 1.0.0.1" fixes the bug temporarily until the plugin is activated again.

Addon Mozilla Archive Format 0.19.3 causes a similar unresponsive script.

Maybe there is an interaction between the plugin and the addon....
(Reporter)

Comment 3

8 years ago
...after weeks tinkering with this nerve-wracking bug I think having found a sensible solution / workaround of this bug...

If I open a second tab (regardless what the content is, on my PC it is the Google starting site) additionally to the desired website I want to save completely or parts of it, the script is performed immediately without any delay or warning message (also with activated addon "Mozilla Archive Format 0.19.3" and "Mozilla Default Plug-in 1.0.0.15")... Strange...

Please state if this procedure also solve your problems.....
(Reporter)

Comment 4

8 years ago
The link
https://support.mozilla.com/en-US/forum/1/649334
does not work anymore, so all info of other users suffering from this bug are lost.
Do not know why the link was removed....

Comment 5

7 years ago
related to bug 500237?

Unfortunately, without testcase the bug is incomplete.
Do you have another testcase?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 6

7 years ago
The effect seems to be the same as bug 500237.
Is there a resolution for that?
What dou you mean with 'another testcase'?
(Reporter)

Comment 7

7 years ago
I'm still chasing the bug...
Now I tentatively disabled ALL Firefox-Plugins (not Addons). At the moment it seems to be working...
Now I'll need to activate the plugins one afte the other and check which one causes the problem...
(Reporter)

Comment 8

7 years ago
Negative.
Trying to save the picture
http://upload.wikimedia.org/wikipedia/commons/9/9c/Henry_Rifle_Receiver.JPG
causes the effect again
You need to log in before you can comment on or make changes to this bug.