Closed Bug 576558 Opened 11 years ago Closed 9 years ago

Full-screen video displays black screen

Categories

(Core :: Graphics, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: merike, Unassigned)

Details

When switching video to fullscreen sound continues to play but screen goes black. Occasionally though very rarely frame flickers. This doesn't happen with Firefox 3.6.6. Tried with example video on http://en.wikipedia.org/wiki/Ogv

From error console:
OpenGL LayerManager Initialized Succesfully.
Version: 1.4 Mesa 7.7.1
Vendor: Tungsten Graphics, Inc
Renderer: Mesa DRI Intel(R) 945GM GEM 20091221 2009Q4 x86/MMX/SSE2
FBO Texture Target: TEXTURE_2D
Build is Mozilla/5.0 (X11; U; Linux i686; et; rv:2.0b2pre) Gecko/20100702 Minefield/4.0b2pre
I confirm HTML5 video goes black after switching to fullscreen since the landing of OpenGL fullscreen on my netbook with Ubuntu 10.04 and Intel graphics.

Same console message:
OpenGL LayerManager Initialized Succesfully.
Version: 1.4 Mesa 7.7.1
Vendor: Tungsten Graphics, Inc
Renderer: Mesa DRI Intel(R) 945GME GEM 20091221 2009Q4 x86/MMX/SSE2
FBO Texture Target: TEXTURE_2D

Mozilla/5.0 (X11; Linux i686; fr; rv:2.0b2pre) Gecko/20100717 Minefield/4.0b2pre
(In reply to comment #2)
> Version: 1.4 Mesa 7.7.1

We shouldn't even be trying to use opengl on that hardware...
Has this one been fixed? That message doesn't appear in error console any more and video plays ok in 4b2, no black screen is present. Or are there any further improvements planned other than not using opengl with that driver?
Closing as there's no black screen and opengl isn't used either.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.