Last Comment Bug 576558 - Full-screen video displays black screen
: Full-screen video displays black screen
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86 Linux
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Milan Sreckovic [:milan]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-02 09:59 PDT by Merike Sell (:merike)
Modified: 2012-04-08 02:10 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Merike Sell (:merike) 2010-07-02 09:59:31 PDT
When switching video to fullscreen sound continues to play but screen goes black. Occasionally though very rarely frame flickers. This doesn't happen with Firefox 3.6.6. Tried with example video on http://en.wikipedia.org/wiki/Ogv

From error console:
OpenGL LayerManager Initialized Succesfully.
Version: 1.4 Mesa 7.7.1
Vendor: Tungsten Graphics, Inc
Renderer: Mesa DRI Intel(R) 945GM GEM 20091221 2009Q4 x86/MMX/SSE2
FBO Texture Target: TEXTURE_2D
Comment 1 Merike Sell (:merike) 2010-07-02 10:01:01 PDT
Build is Mozilla/5.0 (X11; U; Linux i686; et; rv:2.0b2pre) Gecko/20100702 Minefield/4.0b2pre
Comment 2 J. Gatellier 2010-07-17 09:18:28 PDT
I confirm HTML5 video goes black after switching to fullscreen since the landing of OpenGL fullscreen on my netbook with Ubuntu 10.04 and Intel graphics.

Same console message:
OpenGL LayerManager Initialized Succesfully.
Version: 1.4 Mesa 7.7.1
Vendor: Tungsten Graphics, Inc
Renderer: Mesa DRI Intel(R) 945GME GEM 20091221 2009Q4 x86/MMX/SSE2
FBO Texture Target: TEXTURE_2D

Mozilla/5.0 (X11; Linux i686; fr; rv:2.0b2pre) Gecko/20100717 Minefield/4.0b2pre
Comment 3 Vladimir Vukicevic [:vlad] [:vladv] 2010-07-17 12:08:05 PDT
(In reply to comment #2)
> Version: 1.4 Mesa 7.7.1

We shouldn't even be trying to use opengl on that hardware...
Comment 4 Merike Sell (:merike) 2010-08-07 06:50:56 PDT
Has this one been fixed? That message doesn't appear in error console any more and video plays ok in 4b2, no black screen is present. Or are there any further improvements planned other than not using opengl with that driver?
Comment 5 Merike Sell (:merike) 2012-04-08 02:10:47 PDT
Closing as there's no black screen and opengl isn't used either.

Note You need to log in before you can comment on or make changes to this bug.