Closed Bug 576605 Opened 10 years ago Closed 9 years ago

intermittent mochitest-other failure in browser/base/content/test/browser_tabMatchesInAwesomebar.js 10 failures starting with url is in db, should be in tab: null

Categories

(Firefox :: Address Bar, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 4.0b9

People

(Reporter: tnikkel, Unassigned)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1278096486.1278097900.10344.gz
s: talos-r3-snow-029
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/base/content/test/browser_tabMatchesInAwesomebar.js | url is in db, should be in tab: null
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/base/content/test/browser_tabMatchesInAwesomebar.js | db count (1) should match actual open tab count (undefined): null - Got undefined, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/base/content/test/browser_tabMatchesInAwesomebar.js | url is in db, should be in tab: null
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/base/content/test/browser_tabMatchesInAwesomebar.js | db count (1) should match actual open tab count (undefined): null - Got undefined, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/base/content/test/browser_tabMatchesInAwesomebar.js | url is in db, should be in tab: null
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/base/content/test/browser_tabMatchesInAwesomebar.js | db count (1) should match actual open tab count (undefined): null - Got undefined, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/base/content/test/browser_tabMatchesInAwesomebar.js | url is in db, should be in tab: null
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/base/content/test/browser_tabMatchesInAwesomebar.js | db count (1) should match actual open tab count (undefined): null - Got undefined, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/base/content/test/browser_tabMatchesInAwesomebar.js | url is in db, should be in tab: null
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/base/content/test/browser_tabMatchesInAwesomebar.js | db count (1) should match actual open tab count (undefined): null - Got undefined, expected 1
Attached patch possible patchSplinter Review
this is part of tests patch in Bug 552023, it could work, but i'm waiting for tryserver.

Btw, the problem seems to be the fact visits can be recorder before or after  a tab is loaded the count can increase/decrease at each tab opening. The patch is just trying to give a better ordering to events and checks.

Will tell if tryserver likes it or now.
the fix is still not perfect. open_count in the databse is set to 2, as if a tab would be open twice.
Bug 584658 is probably related, if not the cause.
Depends on: 584658
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1281288987.1281290031.14024.gz
WINNT 5.2 mozilla-central opt test mochitest-other on 2010/08/08 10:36:27

s: win32-slave50
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/base/content/test/browser_tabMatchesInAwesomebar.js | url is in db, should be in tab: null
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/base/content/test/browser_tabMatchesInAwesomebar.js | db count (1) should match actual open tab count (undefined): null - Got undefined, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/base/content/test/browser_tabMatchesInAwesomebar.js | url is in db, should be in tab: null
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/base/content/test/browser_tabMatchesInAwesomebar.js | db count (1) should match actual open tab count (undefined): null - Got undefined, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/base/content/test/browser_tabMatchesInAwesomebar.js | url is in db, should be in tab: null
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/base/content/test/browser_tabMatchesInAwesomebar.js | db count (1) should match actual open tab count (undefined): null - Got undefined, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/base/content/test/browser_tabMatchesInAwesomebar.js | url is in db, should be in tab: null
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/base/content/test/browser_tabMatchesInAwesomebar.js | db count (1) should match actual open tab count (undefined): null - Got undefined, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/base/content/test/browser_tabMatchesInAwesomebar.js | url is in db, should be in tab: null
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/base/content/test/browser_tabMatchesInAwesomebar.js | db count (1) should match actual open tab count (undefined): null - Got undefined, expected 1
Depends on: 586506
Should have been fixed by Places branch merge.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b9
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.