If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

HTML Attach: Attachment colors are used for mail body

VERIFIED DUPLICATE of bug 31052

Status

MailNews Core
MIME
P3
normal
VERIFIED DUPLICATE of bug 31052
17 years ago
9 years ago

People

(Reporter: Udo Richter, Assigned: rhp (gone))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; m18) Gecko/20001020
BuildID:    2000102004 / 20001012

When viewing a mail message with an inline HTML attachment using <body text=#>
colors, the text colors are also used for displaying the main mail body.
Affects plain text and HTML mails except HTML mails with own <body text=#> colors.

Background is always white. See also bug 40546


Reproducible: Always
Steps to Reproduce:
1. Create a HTML file:
<html><body bgcolor=#ff0000 text=#00ff00>attachment</body></html>
2. Create a new message
3. Write a few words into the body
4. Attach the HTML file
5. Do a send later or save to drafts
6. view the saved message

Actual Results:  All text is green.
Background is white in the whole document.

Expected Results:  Text body black on white, Attachment green on red.


For some fun: Attach a HTML file with white-on-black text....
(Assignee)

Comment 1

17 years ago
Yes, this is the infamous "Dead Head" effect :-) See bug #: 31052 

- rhp

*** This bug has been marked as a duplicate of 31052 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
Verifying as a duplicate of bug 31052
'Send Page received with added text in color.'
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.