Last Comment Bug 576707 - [RFE][PATCH] Support for custom scripts in run-mozilla.sh
: [RFE][PATCH] Support for custom scripts in run-mozilla.sh
Status: RESOLVED WONTFIX
:
Product: Firefox
Classification: Client Software
Component: Shell Integration (show other bugs)
: unspecified
: x86 Linux
: -- enhancement (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-02 20:42 PDT by Jouko Orava
Modified: 2010-07-19 13:11 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch for build/unix/run-mozilla.sh against mozilla-1.9.2. (770 bytes, patch)
2010-07-02 20:46 PDT, Jouko Orava
no flags Details | Diff | Review

Description Jouko Orava 2010-07-02 20:42:11 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.3) Gecko/20100423 Ubuntu/10.04 (lucid) Firefox/3.6.3
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.3) Gecko/20100423 Ubuntu/10.04 (lucid) Firefox/3.6.3

I keep runtime copies of my Firefox profiles on a small ramdisk. A helper script packs and unpacks the profiles when needed. Originally, I ran the script from session management (GDM), but that proved unreliable (bug reported), and difficult to maintain across updates.

Currently, I use a modified run-mozilla.sh script, which runs the session helper script for the first and last instances of firefox-bin; this works very well. The relevant patch to run-mozilla.sh is attached.

(An even better solution would be to add entries RunFirst= and RunLast= into profiles.ini; RunFirst executed before opening the profile (for the first instance), and RunLast after closing the profile (for the last instance). This way only the active profiles would be put on the ramdisk. Personally, I tend to use only one profile, so modifying run-mozilla.sh is sufficient for me.)

Reproducible: Always
Comment 1 Jouko Orava 2010-07-02 20:46:16 PDT
Created attachment 455821 [details] [diff] [review]
Patch for build/unix/run-mozilla.sh against mozilla-1.9.2.
Comment 2 Kevin Brosnan 2010-07-11 14:12:28 PDT
You will need to get review from the module owner for the patch to be accepted. https://developer.mozilla.org/En/Developer_Guide/How_to_Submit_a_Patch#Getting_Reviews

I'm not sure who should be suggested for the code review. Checking on irc://irc.mozilla.org/#developers should get you a name.
Comment 3 Benjamin Smedberg [:bsmedberg] 2010-07-12 10:23:41 PDT
I do not want to accept the complexity of this code, especially because run-mozilla is not used in most distros. You should continue to use your own wrappers.

Note You need to log in before you can comment on or make changes to this bug.