Dataloss: lost Sidebar tabs list after adding a new profile

RESOLVED WORKSFORME

Status

SeaMonkey
Sidebar
--
critical
RESOLVED WORKSFORME
17 years ago
9 years ago

People

(Reporter: johng, Unassigned)

Tracking

(Blocks: 1 bug, {dataloss})

Trunk
x86
Other
dataloss

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rtm-])

(Reporter)

Description

17 years ago
When I created a new profile and opened it, and lost my custom tabs in My
Sidebar in my regular profile.  It is as if My Sidebar tabs were no longer a
profile specific thing .....

Detail Repro Steps (win95 build 2000101709)

- Launch your regular profile, customize My Sidebar by adding and deleting tabs
as you like so it is a unique list.
- Quit, then launch.  I was offline when I did the next steps.
- At the profile manager, create a new profile.  (When I did this, I also
deleted an old profile, but not my regular profile that I have customized.)
- Launch the new profile, see that it has the default tab list.
- Quit, then launch, but this time choose your regular profile.

Actual Results:
- Instead of seeing your customized list of Sidebar tabs in your regular
profile, you see the default list that is generated when you create a new profile.

Expected Results:
- The tabs for each profile should be maintained.
(Reporter)

Comment 1

17 years ago
adding keywords dataloss and rtm.

Want QA to verify how easy or hard this is to reproduce to see if this really is
a big problem.

cc'ing pchen since he implemented the default list, plus don to get on radar.
Keywords: dataloss, rtm

Comment 2

17 years ago
I tried your steps. Looks fine to me on today's branch build on windows NT. My 
Sidebar list was retained and I did not lose any tabs.

Comment 3

17 years ago
Minus.  I also don't see the problem.  John, is this still happening for you?

Should we close this as WORKSFORME?
Whiteboard: [rtm-]

Comment 4

17 years ago
spam : changing qa to sujay (New Sidebar QA)
QA Contact: shrir → sujay

Comment 5

17 years ago
nav triage team:

Sujay, can you reproduce this with a current build?

Comment 6

17 years ago
can't reproduce...John, is this still a problem for you ?

Updated

17 years ago
Keywords: nsbeta1-
Target Milestone: --- → Future

Comment 7

17 years ago
nav triage team:

tpringle says that he say this happen with a recent build on mtsai's machine.

Comment 8

16 years ago
reassigning matt's old bugs.
Assignee: matt → sgehani

Updated

16 years ago
Blocks: 123929

Comment 9

15 years ago
By the definitions on <http://bugzilla.mozilla.org/bug_status.html#severity> and
<http://bugzilla.mozilla.org/enter_bug.cgi?format=guided>, crashing and dataloss
bugs are of critical or possibly higher severity.  Only changing open bugs to
minimize unnecessary spam.  Keywords to trigger this would be crash, topcrash,
topcrash+, zt4newcrash, dataloss.
Severity: normal → critical

Comment 10

15 years ago
This bug is a duplicate of Bug 119975

Comment 11

15 years ago
On a Win2000 notebook I added another administrator user, and used Mozilla with
that account, which means that a new Mozilla profile was automatically created.
When I logged in using the old admin user all personally added tabs were lost. I
mean all tabs besides similar websites, search, the tinderboxes, bookmarks and
history.

When I came back from my holidays I noticed that also on my Linux machine all
personally added tabs are gone! I really don't know why. Where can I get them
back? I mean in which file are you keeping the list of the tabs, so that I can
fetch it from a backup tape? Another interesting thing: when I open about: using
the affected user mozilla displays:
Mozilla 1.2
Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.2; MultiZilla v1.5.0.1) Gecko/20030701

which is wrong because I use the mozilla-1.4 RPMs. Using root I get the right
version information:
Mozilla 1.4
Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.4; MultiZilla v1.5.0.1) Gecko/20030701

Comment 12

15 years ago
This is not a dup of bug 119975 - that describes a blank sidebar (default
background colour), this describes loss of custom sidebars and a reversion to
the default set (search, history, tinderbox etc.)

I've seen these symptoms (reverting to default tabs) with mozilla 1.4 on linux,
but I didn't create a new profile. I think all I did was close all browser
windows and then try to launch mozilla again before the process had completely
exited. I'll try to reproduce it and either file a new bug or add to this one.

Comment 13

15 years ago
The bug I described in #12 appears to be bug 210051 rather than this one, so
I'll comment on it there.

Comment 14

14 years ago
I lost again my sidebar on my linux box! When I logged in this morning the
sidebar was empty and panels.rdf was gone. I had to get it back from a backup.
It's really getting dangerous now. I can not tell why it happened. Yesterday it
worked, and I restarted mozilla sometimes. Can it be a problem when mozilla was
several hours not running? I suspect a download error when mozilla tries to load
all HTML pages in my open tabs in the main window and in the tabs of the
siderbar on start-up. The only hint that I have is that I sometimes
disable/enable the sidebar using F9. But data loss only happens when starting
the program.
For me that's not only P3.

Comment 15

14 years ago
I lost again my sidebar tabs with 1.4!

I started mozilla. The last page from the previous session was loaded. It's a
page that requires basic authentication. The user/pass dialog opened. Sidebar
showed no tabs at this moment. I cancelled the dialog. The protected page was
displayed in a broken way using cached data. Still no tabs. I loaded a page
without authentication to get rid of the dialog when starting mozilla and then
restarted the application. My tabs were lost. The default panel.rdf was
displayed which I had to replace again with my backup. Curious thing: my mozilla
is configured to show the home page not the last page. Any problem with
protected sites here? Why do I lose my tabs? Race condition with the dialog?

Comment 16

14 years ago
This bug hit me several times the last days running

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

on Windows XP Pro. The sidebar switched back to the normal configuration
(including that "What's Related" tab I don't like).

I haven't found out under which circumstances this bug is reproducible. 

Comment 17

14 years ago
When trying to move my old Mozilla profiles (from an old Windows user directory
after a reinstall) and pasted it, overwriting the newly installed Mozilla's
"Default" profile, I lost several options such as the "file" and "bookmark"
menu. Upon closing and reopening Mozilla, the file menu bar vanished altogether.
I somehow got it to return but ctrl+B can't open the bookmark manager. I just
want my bookmarks to be imported!
Product: Browser → Seamonkey

Comment 18

12 years ago
During the online-session i shut down Moz and could not reopen.A "profile manager" appeard (that profile manager never appeard before). But now, after ceating a profile first access was denied, after a new start of XP, then  dataloss was completed: configuration, bookmarks etc.  
Assignee: samir_bugzilla → nobody
Priority: P3 → --
QA Contact: sujay → sidebar
Target Milestone: Future → ---

Comment 19

9 years ago
The last post here was three years ago. The issue reported was resolved at the
latest in bug 374945 (implementation of Places). 

Resolving WFM.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.