Last Comment Bug 576867 - "Firefox is already running, but is not responding" window has no icon
: "Firefox is already running, but is not responding" window has no icon
Status: RESOLVED FIXED
[polish-p5]
: polish, regression
Product: Core
Classification: Components
Component: Widget: Win32 (show other bugs)
: Trunk
: x86 Windows XP
: -- trivial with 1 vote (vote)
: mozilla9
Assigned To: Brian R. Bondy [:bbondy]
:
Mentors:
Depends on: 491947
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-04 07:10 PDT by Andrés Delfino
Modified: 2011-09-02 05:30 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Screenshot (4.69 KB, image/png)
2010-07-04 07:11 PDT, Andrés Delfino
no flags Details
Patch for no icon (2.58 KB, patch)
2011-08-19 07:47 PDT, Brian R. Bondy [:bbondy]
benjamin: feedback+
Details | Diff | Splinter Review
Patch for wrong icon v2 (2.58 KB, patch)
2011-08-25 13:37 PDT, Brian R. Bondy [:bbondy]
neil: review+
Details | Diff | Splinter Review

Description Andrés Delfino 2010-07-04 07:10:37 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.6) Gecko/20100625 (CK-IBM) Firefox/3.6.6 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; Windows NT 5.1; en-US; rv:2.0b2pre) Gecko/20100704 Minefield/4.0b2pre

"Firefox is already running, but is not responding" window has no icon. See screenshot for details.

Reproducible: Always
Comment 1 Andrés Delfino 2010-07-04 07:11:07 PDT
Created attachment 455946 [details]
Screenshot
Comment 2 Andrés Delfino 2010-07-04 07:16:21 PDT
This is a regression with respect to Firefox 3.6.6.
Comment 3 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2010-07-04 18:46:45 PDT
Jim, could this be a titlebar drawing regression?
Comment 4 Jim Mathies [:jimm] 2010-07-04 18:55:10 PDT
Don't see how that would cause something like this, it's caused by a hung process, which could be anything.
Comment 5 Andrés Delfino 2010-07-05 05:19:42 PDT
Please note that I'm referring to the icon that should be at the left of the message, and not in the titlebar.
Comment 6 Brian R. Bondy [:bbondy] 2011-08-19 07:47:43 PDT
Created attachment 554415 [details] [diff] [review]
Patch for no icon

The problem was that we were using a confirm box with only an OK button when we didn't have a profile unlocker supplied at startup.
I now use an alert box with a warning icon in that case.
Comment 7 Brian R. Bondy [:bbondy] 2011-08-19 07:49:29 PDT
By the way it was showing an icon for me but it was the wrong icon (a question mark) and should be an alert as the patch does.
Comment 8 neil@parkwaycc.co.uk 2011-08-19 13:35:37 PDT
Comment on attachment 554415 [details] [diff] [review]
Patch for no icon

I'm guessing this needs (sub)moa.
Comment 9 neil@parkwaycc.co.uk 2011-08-25 13:01:52 PDT
Comment on attachment 554415 [details] [diff] [review]
Patch for no icon

>-      flags =
>+      PRUint32 flags =
Since we're no longer changing the flags, can we make this const?

>-        nsIPromptService::BUTTON_TITLE_CANCEL * nsIPromptService::BUTTON_POS_0 +
>-        nsIPromptService::BUTTON_TITLE_IS_STRING * nsIPromptService::BUTTON_POS_1 +
>+        (nsIPromptService::BUTTON_TITLE_CANCEL * 
>+         nsIPromptService::BUTTON_POS_0) +
>+        (nsIPromptService::BUTTON_TITLE_IS_STRING * 
>+         nsIPromptService::BUTTON_POS_1) +
Why this change?
Comment 10 Brian R. Bondy [:bbondy] 2011-08-25 13:21:42 PDT
> can we make this const?

Sure I'll submit an updated patch.

> Why this change?

The logic is the same, but I changed it to fix the line length >80. The parentheses are just for easier code readability.
Comment 11 Brian R. Bondy [:bbondy] 2011-08-25 13:37:22 PDT
Created attachment 555826 [details] [diff] [review]
Patch for wrong icon v2

Added const to the flags variable.
Comment 12 Marco Bonardo [::mak] 2011-08-27 01:46:54 PDT
http://hg.mozilla.org/mozilla-central/rev/84cf502e938a
Comment 13 Justin Dolske [:Dolske] 2011-09-02 00:50:09 PDT
*headscratch*

Did you test the |if (aUnlocker)| code path, which still uses confirmEx()? And was it showing any icon?

I ask because the confirmEx() prompt should always be showing an icon (a question-mark icon). So it seems like there's still some bug lurking here as to how we're showing a prompt with _no_ icon...
Comment 14 Justin Dolske [:Dolske] 2011-09-02 00:53:22 PDT
With Firefox 6.0.1 on Windows 7 I get a prompt with a question icon, as expected.
Comment 15 Justin Dolske [:Dolske] 2011-09-02 01:04:20 PDT
Oh, this bug was originally reported against 3.6, and the prompting code's been completely rewritten since then. So unless the "no icon" prompt can be reproduced on a nightly, it's probably just an odd bug in the old code.

I checked Win7 in both Aero and Classic modes, and get icons in both cases.

False alarm! :)
Comment 16 Brian R. Bondy [:bbondy] 2011-09-02 05:30:05 PDT
See Comment 6, and feedback+ from bsmedberg. The problem couldn't be reproduced with no icon but it was suggested to change to a warning icon instead of a question mark.

Note You need to log in before you can comment on or make changes to this bug.