Backspace key doesn't stop across contenteditable spans

RESOLVED DUPLICATE of bug 414526

Status

()

Core
Editor
RESOLVED DUPLICATE of bug 414526
7 years ago
7 years ago

People

(Reporter: Away for a while, Assigned: Away for a while)

Tracking

({testcase})

Trunk
x86
Mac OS X
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
STR:

1. Load the test case: https://bugzilla.mozilla.org/attachment.cgi?id=443835
2. Type something in row 3 and column 2.
3. Press backspace repeatedly.  When the text you just entered is completely deleted, the backspace key would end up deleting the text in the previous contenteditable span.
(Assignee)

Comment 1

7 years ago
Are Google spreadsheets also affected by this bug?  If yes, we need to block on this as well.

Comment 2

7 years ago
We put everything in a single contentEditable div, so I don't think so (though that div may contain multiple spans, but that doesn't appear to be a factor here).

Comment 3

7 years ago
Created attachment 488654 [details]
Simplified test case

Shows this issue happening between two DIV elements.
(Assignee)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 414526
You need to log in before you can comment on or make changes to this bug.