mozilla-central xulrunner nightlies broken since xpcom manifest landing

RESOLVED FIXED

Status

()

Core
XPCOM
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: nthomas, Assigned: Benjamin Smedberg)

Tracking

Trunk
x86
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Seems to be all platforms, here's a linux example from
http://tinderbox.mozilla.org/showlog.cgi?log=XULRunner/1278496950.1278499956.8621.gz

/builds/slave/mozilla-central-linux-xulrunner/build/extensions/java/xpcom/src/nsJavaInterfaces.cpp: In function ‘nsresult InitEmbedding_Impl(JNIEnv*, _jobject*, _jobject*, _jobject*)’:
/builds/slave/mozilla-central-linux-xulrunner/build/extensions/java/xpcom/src/nsJavaInterfaces.cpp:95: error: ‘XRE_InitEmbedding’ was not declared in this scope
/builds/slave/mozilla-central-linux-xulrunner/build/extensions/java/xpcom/src/nsJavaInterfaces.cpp: In function ‘_jobject* Java_org_mozilla_xpcom_internal_XPCOMImpl_getComponentManager(JNIEnv*, _jobject*)’:
/builds/slave/mozilla-central-linux-xulrunner/build/extensions/java/xpcom/src/nsJavaInterfaces.cpp:238: error: incomplete type ‘nsIComponentManager’ used in nested name specifier
/builds/slave/mozilla-central-linux-xulrunner/build/extensions/java/xpcom/src/nsJavaInterfaces.cpp:238: error: expected primary-expression before ‘int’
/builds/slave/mozilla-central-linux-xulrunner/build/extensions/java/xpcom/src/nsJavaInterfaces.cpp:238: error: expected `)' before ‘int’

Broke in this change window:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=82edf5bd1abe&tochange=c173731c9d90

Updated

8 years ago
blocking2.0: --- → ?

Updated

8 years ago
Blocks: 357052
(Assignee)

Comment 2

8 years ago
Created attachment 457570 [details] [diff] [review]
Disable JavaXPCOM by default
Assignee: nobody → benjamin
Status: NEW → ASSIGNED
Attachment #457570 - Flags: review?(shaver)
Comment on attachment 457570 [details] [diff] [review]
Disable JavaXPCOM by default

Ashes to ashes, JNI thunking to dust.
Attachment #457570 - Flags: review?(shaver) → review+
(Assignee)

Comment 4

8 years ago
http://hg.mozilla.org/mozilla-central/rev/871a801486f3
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Updated

8 years ago
Duplicate of this bug: 582041

Comment 6

8 years ago
Thanks for the fix. However I only see Linux and Mac builds. What about Windows?
(Reporter)

Comment 7

8 years ago
There's a new error in the win32 build, eg
  http://tinderbox.mozilla.org/showlog.cgi?log=XULRunner/1280224959.1280232071.28289.gz
Please file a separate bug for that.

Comment 8

8 years ago
(In reply to comment #7)
> Please file a separate bug for that.

Done. See bug 582559
(Assignee)

Updated

8 years ago
blocking2.0: ? → betaN+
You need to log in before you can comment on or make changes to this bug.