[10.6] Upon launching: __NSAutoreleaseNoPool() ... leaking messages in console (profile manager window)

RESOLVED FIXED

Status

()

Core
Widget: Cocoa
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: philippe (part-time), Unassigned)

Tracking

(Blocks: 1 bug, {regression})

Trunk
x86
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Console logs the following 4 messages when launching Minefield

7/9/10 12:58:27 PM	firefox-bin[83751]	*** __NSAutoreleaseNoPool(): Object 0x2915de0 of class NSCFString autoreleased with no pool in place - just leaking
7/9/10 12:58:27 PM	firefox-bin[83751]	*** __NSAutoreleaseNoPool(): Object 0x296c0b0 of class TopLevelWindowData autoreleased with no pool in place - just leaking
7/9/10 12:58:27 PM	firefox-bin[83751]	*** __NSAutoreleaseNoPool(): Object 0x2967ba0 of class ToolbarWindow autoreleased with no pool in place - just leaking
7/9/10 12:58:27 PM	firefox-bin[83751]	*** __NSAutoreleaseNoPool(): Object 0x2968f20 of class WindowDelegate autoreleased with no pool in place - just leaking

I tracked this down to _atleast_ the 20100516 build (but could be older)
(Reporter)

Updated

7 years ago
Summary: Upon launching: __NSAutoreleaseNoPool() messages in console → Upon launching: __NSAutoreleaseNoPool() ... leaking messages in console
(Reporter)

Comment 1

7 years ago
Narrow regression range:
no logging:
Gecko/20100420 Minefield/3.7a5pre
http://hg.mozilla.org/mozilla-central/rev/5f229488969c

logging appears:
Gecko/20100421 Minefield/3.7a5pre
http://hg.mozilla.org/mozilla-central/rev/cdc8bf25220e

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5f229488969c&tochange=cdc8bf25220e

--> bug 559473 is suspicious… 


Notes:
1. I don't see this on 10.5

2. With a new profile, I see this one instead of the ToolbarWindow one above
*** __NSAutoreleaseNoPool(): Object 0x29ba0f0 of class BaseWindow autoreleased with no pool in place - just leaking

3. And I forgot to note this one:
*** __NSAutoreleaseNoPool(): Object 0x1c42f2e0 of class __NSFastEnumerationEnumerator autoreleased with no pool in place - just leaking
Component: General → Widget: Cocoa
Keywords: regression
QA Contact: general → cocoa
Summary: Upon launching: __NSAutoreleaseNoPool() ... leaking messages in console → [10.6] Upon launching: __NSAutoreleaseNoPool() ... leaking messages in console
Assignee: nobody → joshmoz
blocking2.0: ? → final+

Comment 2

7 years ago
On a normal Minefield startup on 10.6 I don't see any leaks. I see this if I start up while Firefox is already running and I get an already-running dialog box...

2010-07-19 19:19:13.155 firefox-bin[20911:a0f] *** __NSAutoreleaseNoPool(): Object 0x4808510 of class __NSFastEnumerationEnumerator autoreleased with no pool in place - just leaking
2010-07-19 19:19:13.158 firefox-bin[20911:a0f] *** __NSAutoreleaseNoPool(): Object 0x4824df0 of class TopLevelWindowData autoreleased with no pool in place - just leaking
2010-07-19 19:19:13.159 firefox-bin[20911:a0f] *** __NSAutoreleaseNoPool(): Object 0x49069d0 of class NSCFString autoreleased with no pool in place - just leaking
2010-07-19 19:19:13.160 firefox-bin[20911:a0f] *** __NSAutoreleaseNoPool(): Object 0x4820470 of class ToolbarWindow autoreleased with no pool in place - just leaking
2010-07-19 19:19:13.161 firefox-bin[20911:a0f] *** __NSAutoreleaseNoPool(): Object 0x4822a60 of class WindowDelegate autoreleased with no pool in place - just leaking

Comment 3

7 years ago
I can't reproduce any leaks that would block, we can re-nom later if that changes.
Assignee: joshmoz → nobody
blocking2.0: final+ → ---
(Reporter)

Comment 4

7 years ago
After another round of testing:
1. Under a brand new OS X user account --> leaks on _first launch_ only
2. Under my normal user account --> always leaks.

under [1]: the first thing that is displayed is the 'import data' window.
under [2]: the profile manager is used

in both cases, the logging happens when the window appears.

Updated

7 years ago
Duplicate of this bug: 580275
(In reply to comment #4)

> under [1]: the first thing that is displayed is the 'import data' window.
> under [2]: the profile manager is used

So, [2] should have been fixed by Jonathan's patch in bug 559400, if I read it right, which makes this bug a definite regression from a fix that's only 3 months old. [1] may be the same thing; not sure if it's modal or not.

(Josh's comment 2 is bug 562109.)
(Reporter)

Updated

7 years ago
Duplicate of this bug: 611832
(Reporter)

Updated

7 years ago
Duplicate of this bug: 601959
(Reporter)

Updated

7 years ago
Summary: [10.6] Upon launching: __NSAutoreleaseNoPool() ... leaking messages in console → [10.6] Upon launching: __NSAutoreleaseNoPool() ... leaking messages in console (profile manager window)
(Reporter)

Comment 9

6 years ago
no leaks / logging:
20110410
http://hg.mozilla.org/mozilla-central/rev/fe3f7889918b

20110409
http://hg.mozilla.org/mozilla-central/rev/7d90da136b2c


http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=7d90da136b2c&tochange=fe3f7889918b

Bug 634702 seems to have fixed this.
(Reporter)

Comment 10

6 years ago
given bug 634702 comment  7, closing as fixed by bug 634702.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.