Table border attribute with value "0px" renders border

RESOLVED DUPLICATE of bug 539880

Status

()

RESOLVED DUPLICATE of bug 539880
8 years ago
8 years ago

People

(Reporter: andrejohn.mas, Unassigned)

Tracking

({regression, testcase})

Trunk
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:2.0b1) Gecko/20100630 Firefox/4.0b1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:2.0b1) Gecko/20100630 Firefox/4.0b1

If you specify a table with the following:

  <table border="0px">
    <tr><td>A</td><td>B</td><td>B</td></tr>
    <tr><td>D</td><td>E</td><td>F</td></tr>
  </table>

the cell borders get rendered. While I realise the value specified should be 'border="0"', and so technically an error in the HTML, the way this is handled in Firefox 4b1 is different to previous Firefox versions and different to the other browsers. Other browsers (Opera, Safari, FF3.6.x) do not render the borders in this case.

Reproducible: Always
(Reporter)

Comment 1

8 years ago
Created attachment 456568 [details]
Test case illustrating the bug

Attached a test case

Comment 2

8 years ago
Confirmed on Windows, works with 1.9.2
Status: UNCONFIRMED → NEW
Component: General → Layout
Ever confirmed: true
Keywords: regression, testcase
OS: Mac OS X → All
Product: Firefox → Core
QA Contact: general → layout
Hardware: x86 → All
Summary: FF4b1: Table border attribute with value "0px" renders border → Table border attribute with value "0px" renders border
Version: unspecified → Trunk
Hmm.   This is a regression from bug 43178.

Can anyone tell what the set of values is that should trigger no border, exactly?  We may just need to add a new selector for this or something.
Blocks: 43178
blocking2.0: --- → ?

Comment 4

8 years ago
Created attachment 456584 [details]
testcase with more values

shows what 1.9.2 and other browsers do in various cases

Comment 5

8 years ago
Created attachment 456599 [details]
testcase, corrected
Attachment #456584 - Attachment is obsolete: true

Comment 6

8 years ago
Created attachment 456600 [details]
testcase with more invalid values

Sorry for the spam, got it now.
Attachment #456599 - Attachment is obsolete: true

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 539880
blocking2.0: ? → ---
You need to log in before you can comment on or make changes to this bug.