Last Comment Bug 577848 - Flash video player doesn't display on website giantbomb.com
: Flash video player doesn't display on website giantbomb.com
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: x86 Windows 7
: -- normal with 4 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://www.giantbomb.com/videos/
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-10 11:33 PDT by Tim Meader
Modified: 2011-08-04 09:03 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Bad version from trunk build (158.28 KB, image/jpeg)
2010-07-10 11:51 PDT, Tim Meader
no flags Details
Good version from 3.6.7 beta1 (152.08 KB, image/jpeg)
2010-07-10 11:52 PDT, Tim Meader
no flags Details

Description Tim Meader 2010-07-10 11:33:35 PDT
The video player for the website giantbomb.com doesn't launch when viewed using the Firefox 4.0b2pre 20100710 build.
Comment 1 Tim Meader 2010-07-10 11:50:11 PDT
Disabling IPC and D2D acceleration has no effect. Attaching comparison screenshots. "Bad" is from Trunk build, "good" is from 3.6.7 Beta1.
Comment 2 Tim Meader 2010-07-10 11:51:04 PDT
Created attachment 456687 [details]
Bad version from trunk build
Comment 3 Tim Meader 2010-07-10 11:52:41 PDT
Created attachment 456689 [details]
Good version from 3.6.7 beta1
Comment 4 Alice0775 White 2010-07-10 13:53:00 PDT
Regression window:
Works:
http://hg.mozilla.org/mozilla-central/rev/b7f3c1c9fb57
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091201 Minefield/3.7a1pre ID:20091201052221

Fails:
http://hg.mozilla.org/mozilla-central/rev/a5e1b195ecf7
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091202 Minefield/3.7a1pre ID:20091202045824

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b7f3c1c9fb57&tochange=a5e1b195ecf7
Comment 5 Alice0775 White 2010-07-10 14:08:53 PDT
Regression window in tracemonkey build

Works:
http://hg.mozilla.org/tracemonkey/rev/c84622414ed3
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091119 Minefield/3.7a1pre ID:20091119045932

Fails:
http://hg.mozilla.org/tracemonkey/rev/2ca2a236da89
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091120 Minefield/3.7a1pre ID:20091120052422

Pushlog:
http://hg.mozilla.org/tracemonkey/pushloghtml?fromchange=c84622414ed3&tochange=2ca2a236da89
Comment 6 José Jeria 2010-08-24 12:59:04 PDT
Error console:
Error: LaunchPad is undefined
Source File: http://media.giantbomb.com/media/video/js/video_10027.js
Line: 1
Comment 7 Tim Meader 2010-08-25 09:47:18 PDT
Yeah, not sure what the issue is here, since loading up this page in FF 3.6.8 reports no errors at all in the Error Console. A refresh of the page in the 08/24 nightly for Firefox 4 returns the following console errors:

Error: assignment to undeclared variable _VINES_RANDOM_IDS
Source File: http://media.giantbomb.com/media/vine/js/base_10031.js
Line: 1

Error: LaunchPad is undefined
Source File: http://media.giantbomb.com/media/video/js/video_10027.js
Line: 1

Error: assignment to undeclared variable QUESTMANAGER
Source File: http://media.giantbomb.com/media/quest/js/quest_10008.js
Line: 1

Error: _VINES_RANDOM_IDS is not defined
Source File: http://media.giantbomb.com/media/vine/js/base_10031.js
Line: 1

Error: 'caller', 'callee', and 'arguments' properties may not be accessed on strict mode functions or the arguments objects for calls to them
Source File: http://media.giantbomb.com/media/vine/js/mootools-1.2.4-core-nc_10001.js
Line: 1

Going to post this on the site's support forum as well so hopefully their devs can take a look. This definitely appears to be JS changes between FF3 and FF4 that's the culprit here though.
Comment 8 Thorsten Gebuhr 2010-09-12 09:54:14 PDT
Probably I've got the same error on this (german) Page:
http://vid.buffed.de/v/tHeI18ASW2E/buffedShow/buffedShow-207/

With FF 4 beta 4 and 5 (not tested earlier beta-versions) instead of showing the Flash-Video there's only a white Flash-frame.

Expected:
First this side shows a short add-video an then the main-video.

It workes in FF 3.6 and any other browser. When testing make sure you don't try to block adds, since this may interfere with the add-video.
Comment 9 Alice0775 White 2010-10-25 18:27:34 PDT
http://media.giantbomb.com/media/vine/js/base_10031.js  starts with "use strict";

Maybe same as Bug 607188. and Tech Evangelism .
Comment 10 Tim Meader 2011-08-04 09:03:50 PDT
Fixed by the website author. Closing.

Note You need to log in before you can comment on or make changes to this bug.