Closed Bug 577851 Opened 9 years ago Closed 9 years ago

config.cgi does not work in 3.4.7

Categories

(Bugzilla :: Bugzilla-General, defect, critical)

3.4.7
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Bugzilla 3.4

People

(Reporter: Frank, Assigned: LpSolit)

References

()

Details

(Keywords: regression, Whiteboard: [doesn't affect 3.6 or newer])

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_4; de-de) AppleWebKit/533.16 (KHTML, like Gecko) Version/5.0 Safari/533.16
Build Identifier: 3.4.7

After upgrade from 3.4.6 to 3.4.7  the configuration  load did not.

Error: Can't locate object method "match" via package "Bugzilla::Component" at Bugzilla/Product.pm line 138.

Reproducible: Always

Steps to Reproduce:
1. try to get the config with ...config.cgi?ctype=rdf

Actual Results:  
Error:

Can't locate object method "match" via package "Bugzilla::Component" at Bugzilla/Product.pm line 138.

Expected Results:  
xml with the configuration
We indeed regressed it, I think due to bug 553255. This is a major regression, so I will take it for 3.4.8.
Severity: normal → critical
Status: UNCONFIRMED → NEW
Depends on: 553255
Ever confirmed: true
Flags: blocking3.4.8+
Keywords: regression
Target Milestone: --- → Bugzilla 3.4
Version: unspecified → 3.4.7
Bugzilla 3.6 and newer are not affected. 3.4.7 only.
Whiteboard: [doesn't affect 3.6 or newer]
The simplest fix is to stop making it use preload on 3.4, I think.

I'm surprised nobody reported this before, since the code was live on bmo and was the backend of BzAPI.
A simple test that just tries to load config.cgi would probably be good.
Flags: testcase?
Summary: config.cgi?ctype=rdf did not work in 3.4.7 → config.cgi?ctype=rdf does not work in 3.4.7
(In reply to comment #1)
> We indeed regressed it, I think due to bug 553255. This is a major regression,
> so I will take it for 3.4.8.

Yes, when I comment the line

 Bugzilla::Product::preload($vars->{'products'}); 

I get the configuration.
(In reply to comment #4)
> A simple test that just tries to load config.cgi would probably be good.

We have one for a very long time. But test_config.cgi only loads the JS version of the script, not the RDF one (I would have to check, but I'm not sure Selenium is able to parse the output correctly).
Oh, wow, no need for the RDF template. The JS one is broken too, so my test was supposed to catch the problem.
Summary: config.cgi?ctype=rdf does not work in 3.4.7 → config.cgi does not work in 3.4.7
OK, I don't get it. If I remove this line from test_config.t:

 set_parameters($sel, { "User Authentication" => {"requirelogin-on" => undef} });

then the script fails, as expected (same error as in comment 0). But if I leave it, then the script passes, and config.cgi doesn't crash?!
Flags: testcase?
Attached patch patch, v1Splinter Review
Backout bug 553255 for 3.4.x.
Assignee: general → LpSolit
Status: NEW → ASSIGNED
Attachment #456727 - Flags: review?(mkanat)
Comment on attachment 456727 [details] [diff] [review]
patch, v1

This works just as well as my other patch, but I suppose it is more reliable and simple as a fix?
Attachment #456727 - Flags: review?(mkanat) → review+
Flags: approval3.4+
Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/3.4/
modified config.cgi
Committed revision 6765.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.