Note: There are a few cases of duplicates in user autocompletion which are being worked on.

E-mail notifications are missing datetime for comments

RESOLVED FIXED in Bugzilla 3.6

Status

()

Bugzilla
Email Notifications
--
minor
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: reed, Assigned: Frédéric Buclin)

Tracking

(Blocks: 1 bug, {regression})

3.6.1
Bugzilla 3.6
regression
Dependency tree / graph
Bug Flags:
approval +
approval4.0 +
blocking4.0 +
approval3.6 +
blocking3.6.2 +

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
The "comment from" lines in e-mail notifications are missing their datetime (it's blank).

Example:
--- Comment #5 from Reed Loden [:reed] <reed@reedloden.com>  ---

LpSolit said he was seeing this upstream, as well.
Flags: blocking4.0?
Flags: blocking3.6.2?
(Reporter)

Updated

7 years ago
Keywords: regression
(Assignee)

Comment 1

7 years ago
Note that I'm personally in favor of having the date going away definitely as this information is already in the Date: header of bugmails.
(Assignee)

Comment 2

7 years ago
Created attachment 456825 [details] [diff] [review]
patch, v1

The method to get the time when a comment was added is creation_ts(), not time().
Assignee: email-notifications → LpSolit
Status: NEW → ASSIGNED
Attachment #456825 - Flags: review?(bugzilla)
(Assignee)

Comment 3

7 years ago
This is a regression due to bug 472217, which changed $comment->{'time'} to $comment->creation_ts (internally: $comment->{'bug_when'}). So this affects 3.6 and newer only.
Severity: normal → minor
Depends on: 472217
Comment on attachment 456825 [details] [diff] [review]
patch, v1

r=glob
Attachment #456825 - Flags: review?(bugzilla) → review+
Flags: approval?
(Reporter)

Updated

7 years ago
Flags: approval4.0?
Flags: approval3.6?

Comment 5

7 years ago
  However, I do agree with LpSolit--for any branch where reed's fix went in that makes the Date header reflect delta_ts, it's probably unnecessary to include dates in the comment headers. The only case that this would be useful for is if there are multiple comments in one email, but that is a pretty rare case.
Flags: blocking4.0?
Flags: blocking4.0+
Flags: blocking3.6.2?
Flags: blocking3.6.2+
Flags: approval?
Flags: approval4.0?
Flags: approval4.0+
Flags: approval3.6?
Flags: approval3.6+
Flags: approval+

Comment 6

7 years ago
  (The non-inclusion of Date headers should be a separate bug though.)
(Assignee)

Comment 7

7 years ago
Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/trunk/
modified template/en/default/email/newchangedmail.txt.tmpl
Committed revision 7329.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/4.0/
modified template/en/default/email/newchangedmail.txt.tmpl
Committed revision 7307.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/3.6/
modified template/en/default/email/newchangedmail.txt.tmpl
Committed revision 7132.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.