Closed Bug 578150 Opened 10 years ago Closed 10 years ago

New crasher in 3.6.7, [@ nsGlobalWindow::DispatchDOMWindowCreated()], likely caused by bug 567357

Categories

(Core :: DOM: Core & HTML, defect, critical)

1.9.2 Branch
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Tracking Status
blocking1.9.2 --- .7+
status1.9.2 --- .7-fixed

People

(Reporter: christian, Assigned: sicking)

References

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

Depends on: 567357
Keywords: regression
Summary: New crasher in 3.6.7, likely caused by bug 567357 → New crasher in 3.6.7, [@ nsGlobalWindow::DispatchDOMWindowCreated()], likely caused by bug 567357
It's in the top 10, so marking as a blocker. We'll spin a build #2 for this.
blocking1.9.2: --- → .7+
Keywords: crash
Assignee: nobody → jonas
Attached patch Patch to fixSplinter Review
This should do it. It seems like we're dropping our current document somewhere along the way.
Attachment #456937 - Flags: review?(mrbkap)
The above patch should apply fine on the branches too.
Attachment #456937 - Flags: review?(mrbkap) → review+
Comment on attachment 456937 [details] [diff] [review]
Patch to fix

a=LegNeato for 1.9.2.7. Please land on mozilla-1.9.2 default AND mozilla-1.9.2 GECKO1927_20100701_RELBRANCH
Attachment #456937 - Flags: approval1.9.2.7+
Blocks: 567357
No longer depends on: 567357
(In reply to comment #5)
> Landed on m-c and 1.9.2

Marking fixed based on my assumption that not being marked fixed was an oversight - patch landed on m-c and this is marked fixed on branches.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
I have an unminized testcase, that has the same end stack as this bug, but when reducing it further, I get the stacktrace from bug 574856.
Crash Signature: [@ nsGlobalWindow::DispatchDOMWindowCreated()]
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.