Hangs when opening Aspera file selection dialog box

RESOLVED FIXED

Status

()

Core
Plug-ins
--
critical
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: Christian Flanagan, Assigned: jimm)

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.10) Gecko/20100504 Firefox/3.5.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6

We have an existing application that uses Aspera Connect client for users to upload files. We've verified the problem occurs with Firefox 3.6.6 and 3.6.4 using the Aspera Connect 2.3.1 and 2.4.0. In Firefox 3.5.10, the problem disappears with either Aspera Connect 2.3.1 and 2.4.0. I've contacted Aspera and asked for their 2.3.0 version of the client. It might not have this problem, but I can't verify it at the moment. Our application is built on the Flash Platform. We haven't verified that this problem exists with just a simple HTML form, but that's possible.

Reproducible: Always

Steps to Reproduce:
1. Create a Flash .fla file. Populate the stage with a button. Write a button click handler that calls a JavaScript function. (ex. ExternalInterface.call("openAsperaDialog", false);)
2. The JavaScript function creates an instance of AsperaWeb and calls the runOpenFileDialog method.
  Example:
function openAsperaDialog() {
  pathArray = new AsperaWeb('aspera-web').runOpenFileDialog(false, browseMultiple);
  return pathArray;
}
3. When the dialog box appears, the dialog and browser hang.
Actual Results:  


In 3.6.4, this happened 1 in 10 tries. In 3.6.6, it happens nearly every time. In some cases, the hang fixed itself after a short period of time. In others, the process had to be killed in order to resolve the hang. The browser doesn't display a "not responding" message. The processor doesn't show a high level of usage.

Expected Results:  
The user selects a file from the dialog and clicks OK. The path to the file is returned to the Flash application.

I've been fighting with this issue for a week. I had tons of tools and the Night Launch theme installed. I uninstalled everything. I killed other programs and services that were running on my computer. I rebooted dozens of times. I've got my machine striped down as far as I can. I've sent communication to Aspera asking for an earlier version of their client that's not available on their website. I will let them know I logged this bug with Mozilla.
From our perspective we see only either HTML websites or we are using plugins like flash. We don't know what's behind it (like PHP, asp).

There is nothing we can do without more information.
Is there a public testurl ?

>The user selects a file from the dialog and clicks OK. The path to the file is
>returned to the Flash application.

That is a file upload prompt from a flash application, right ?
Firefox doesn't send any path information with HTML file upload controls.
Do you tested another browser (except IE) ?
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> From our perspective we see only either HTML websites or we are using plugins
> like flash. We don't know what's behind it (like PHP, asp).

Aspera Connect is behind it.
http://www.asperasoft.com/en/products/client_software_2/aspera_connect_8

> There is nothing we can do without more information.
> Is there a public testurl ?

I'm working on it. I'll post it as soon as possible.

> That is a file upload prompt from a flash application, right ?
> Firefox doesn't send any path information with HTML file upload controls.
> Do you tested another browser (except IE) ?

No, not from Flash, from Aspera Connect. It's an active-x control. Yes, our product has been in service for three years. We test it in Windows and Mac on Safari, IE, and Firefox. This is our first new release since Firefox 3.6. It works in Internet Explorer and Safari.
>Aspera Connect is behind it.
What's behind the html or plugin doesn't matter much for us.

>No, not from Flash, from Aspera Connect. It's an active-x control.
Firefox doesn't support activex Controls as plugin. 
It's either a html file upload control or something from a plugin like flash or java.
Normal html form controls are working ?
You can use the "add an attachment" link in this bug and click on browse.

You should probably attach a stacktrace via the "add an attachment link" using this instructions:
https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg (but mdc seems to be down for me at the moment)
(Reporter)

Comment 4

7 years ago
Created attachment 457385 [details]
Stack Trace from Firefox 3.6.6

I was unable to get WinDbg to run Firefox with examine child processes turned on. I followed the steps at https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg precisely. If I left that one step out, Firefox launched and I was able to continue without a problem.

The output file attached displays a note "Your debugger is not using the correct symbols" that appears after I ran the !anaylze command. I downloaded the symbols from http://symbols.mozilla.org/firefox using the command .sympath SRV*c:\symbols*http://symbols.mozilla.org/firefox. The directory was created with 42 subdirectories with .pdb files in each.
(Reporter)

Comment 5

7 years ago
(In reply to comment #3)

> Firefox doesn't support activex Controls as plugin. 
> It's either a html file upload control or something from a plugin like flash or java.

Right, my bad. There's a Aspera Web Firefox Plugin.

> Normal html form controls are working ?
> You can use the "add an attachment" link in this bug and click on browse.

Yes.

> You should probably attach a stacktrace via the "add an attachment link" using
> this instructions:
> https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg (but mdc
> seems to be down for me at the moment)

Done.
Attachment #457385 - Attachment mime type: application/octet-stream → text/plain
Component: General → IPC
Keywords: hang
Product: Firefox → Core
QA Contact: general → ipc
(Reporter)

Updated

7 years ago
(Reporter)

Comment 6

7 years ago
Added a URL to a test application on our extranet.

I've successfully reproduced the bug in this test application. It might take 10 or 15 tries, but the browser will eventually hang.
I got different results. A windows filepicker opens, it's active (blue titlebar) but somehow doesn't seem to have focus. You can close the filepicker with the taskmanager and you can still work with Firefox after that.

This is the used npapi plugin:
Aspera Web for Firefox

    File: npasperaweb.dll
    Version: 2.4.0.28072
    Aspera Web for Firefox
Status: UNCONFIRMED → NEW
Component: IPC → Plug-ins
Ever confirmed: true
QA Contact: ipc → plugins
jim, more of the same
Assignee: nobody → jmathies

Comment 9

7 years ago
This is Serban Simu - I head up engineering at Aspera, the producer of npasperaweb.dll.  

I would like to summarize the current situation - please correct if I'm wrong:

- the problem only happens with Firefox 3.6.6 on Windows XP (doesn't happen on Vista or Windows 7, or Mac or Linux)

- we don't yet know if this happens on firefox 3.6.8 on Windows XP (we're testing here at Aspera now)

- Matthias has reproduced the problem - 

- the problem only happens when calling the plugin from Flash and it never happens when calling from regular HTML / JavaScript 

@Christian - can you confirm that what Matthias saw is what you reported as the problem?
@Matthias - in the case of the problem you saw, are you interested/able/willing to troubleshoot and pursue a fix?
FYI: I'm only a bug triager here in bugzilla. I request additional information from the reporter that the developers need, filter out all the bugs that are not really a bug in our code and i try to reproduce the reported bugs. I'm sorry but I'm not able to produce a fix.
(Reporter)

Comment 11

7 years ago
Simu, I can't confirm that Firefox does or doesn't hang when calling the Aspera plug-in from plain old HTML/Javascript. 100% of the apps I work on that use Aspera are built in Flash/Flex.

Comment 12

7 years ago
Adding to my summary:

- the same problem happens on firefox 3.6.8 (confirmed by testing at Aspera)

Comment 13

7 years ago
@Mathias: Is there any more information we (Aspera) could provide to help your dev team work on a fix for this ?
My job here is done and only the developers (in this case jmathies@mozilla.com) will ask additional questions if necessary.
(Assignee)

Comment 15

6 years ago
fixed by bug 648935, which will merge to aurora tomorrow.

http://mozilla.github.com/process-releases/draft/development_specifics/
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.