The new title bar should continue to draw the page title

RESOLVED DUPLICATE of bug 575487

Status

()

Core
Widget: Win32
RESOLVED DUPLICATE of bug 575487
8 years ago
8 years ago

People

(Reporter: tmyoung, Unassigned)

Tracking

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
As discussed at the Mozilla Summit: when performing Bug triage or other tasks, the context provided by the page title being listed in title bar is very useful.  For example, as more tabs are open and a user is working with BMO, the bug's number is not fully printed in the tab bar and the title of the bug is not even visible.  It is awkward to scroll from the top of the page and again to the bottom to remind the user of what page he is on.  Since that space is not currently used for anything other than the combined menu, there is no loss in continuing to use some of that screen real estate for the page title again.
(Reporter)

Updated

8 years ago
Blocks: 513162
Component: General → Widget: Win32
Product: Firefox → Core
QA Contact: general → win32
If users will put buttons there, then what? if users will put there tabs, then what?

Updated

8 years ago
Blocks: 556174
No longer blocks: 513162
How about a customizable (removable/relocatable) page title widget?
[See Bug 575487;contain some form of discussion there] 

It is hard for page title and tabs to co-exist in title bar. Reason being the height of the title bar is very short. Putting the page title when tabs are in title bar makes the page title very small and almost unreadable.

One Possible solution is to make use of the Firefox Button. As it has the height of the title bar, and it is easy to see and easy to identify(due to its obvious colour). The possible solution is to put the summarized  page title into the Firefox Button and lengthen it to fit the page title. 

Summarized Page Title mean that it should only contain the information that is important. 

Examples:

Normal Page title  
Bug 578611 - The new title bar should continue to draw the page title 
Blogger: Your blog Name - Manage Posts
Earth - Supreme Commander Wiki - Guides, units, fractions, and more 

Summarized Page title 
Bug 578611
Blogger - Manage Posts
Earth - Supreme Commander Wiki
(Reporter)

Comment 3

8 years ago
I think that is the solution; ideally, there would be three options: full title, trimmed title, and no title.

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 575487
You need to log in before you can comment on or make changes to this bug.