[FF4Beta1] Undo function doesn't work after removing incompatible add-ons

RESOLVED DUPLICATE of bug 553494

Status

()

Toolkit
Add-ons Manager
--
major
RESOLVED DUPLICATE of bug 553494
8 years ago
8 years ago

People

(Reporter: Cihan Ersoy, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:2.0b1) Gecko/20100630 Firefox/4.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:2.0b1) Gecko/20100630 Firefox/4.0b1

Undo function doesn't work while trying to restore a recently removed add-on.

Reproducible: Always

Steps to Reproduce:
1. Go to Tools -> Add-ons
2. Remove an add-on from the list and "Undo" message will appear at the bottom.
3. Click Undo. Nothing happens.
Actual Results:  
Undo didn't work. 

Expected Results:  
Removed add-on should be recovered back.

Using XP SP3 up to date with all updates.
Using FF extensions: AdBlock Plus 1.2.1, Download StatusBar 0.9.6.8.

Build platform
target
i686-pc-mingw32
Build tools
Compiler 	Version 	Compiler flags
cl 	14.00.50727.762 	-TC -nologo -W3 -Gy -Fdgenerated.pdb -DNDEBUG -DTRIMMED -Zi -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
cl 	14.00.50727.762 	-GR- -TP -nologo -Zc:wchar_t- -W3 -Gy -Fdgenerated.pdb -wd4800 -DNDEBUG -DTRIMMED -Zi -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
(Reporter)

Updated

8 years ago
Summary: Undo function doesn't work after removing incompatible add-ons → [FF4Beta1] Undo function doesn't work after removing incompatible add-ons
Group: core-security
Component: General → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: general → add-ons.manager
Version: unspecified → Trunk
Incompatible add-ons are disabled. So it's a dupe of bug 553494.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 553494
You need to log in before you can comment on or make changes to this bug.