NEW, UNCONFIRMED bug is marked in class=strike

VERIFIED FIXED in 1.7.6

Status

Socorro
Webapp
VERIFIED FIXED
8 years ago
7 years ago

People

(Reporter: timeless, Assigned: ryansnyder)

Tracking

({regression})

Trunk
1.7.6
regression
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
ID: <span>30173ccc-0587-4377-8b6f-c09f62100520</span><br> Signature: <span>nsTransformedTextRun::SetCapitalization(unsigned int, unsigned int, unsigned char*, gfxContext*)</span></div>
<div id="report-index" class="flora">

    <ul class="ui-tabs-nav">

        <li class="ui-tabs-selected"><a href="#details"><span>Details</span></a></li>
        <li class=""><a href="#modules"><span>Modules</span></a></li>
        <li class=""><a href="#rawdump"><span>Raw Dump</span></a></li>
        <li class=""><a href="#extensions"><span>Extensions</span></a></li>
        <li class=""><a href="#comments"><span>Comments</span></a></li>
        <li class=""><a href="#correlation"><span>Correlations</span></a></li>

    </ul>
    <div style="display: block;" class="ui-tabs-panel" id="details">
        <table class="list record">
            <tbody><tr>
<th>Signature</th><td>nsTransformedTextRun::SetCapitalization(unsigned int, unsigned int, unsigned char*, gfxContext*)</td>
            </tr>
            <tr>
                <th>UUID</th><td>30173ccc-0587-4377-8b6f-c09f62100520</td>

            </tr>
            <tr>
                <th>Time
</th><td>2010-05-20 00:48:22.742381</td>
            </tr>
            <tr>
                <th>Uptime</th><td>2217</td>
            </tr>

                                    <tr>
		 <th>Install Age</th><td>1216627 seconds (2.0 weeks)  since version was first installed.</td>
            </tr>
                        <tr>
                <th>Product</th><td>Thunderbird</td>
            </tr>
            <tr>

                <th>Version</th><td>3.1b2</td>
            </tr>
            <tr>
                <th>Build ID</th><td>20100430130203</td>
            </tr>
                        <tr>
                <th>Branch</th><td>1.9.2</td>

            </tr>
                        <tr>
                <th>OS</th><td>Windows NT</td>
            </tr>
            <tr>
                <th>OS Version</th><td>5.1.2600 Service Pack 3</td>
            </tr>

            <tr>
                <th>CPU</th><td>x86</td>
            </tr>
            <tr>
                <th>CPU Info</th><td>GenuineIntel family 6 model 23 stepping 10</td>
            </tr>
            <tr>

                <th>Crash Reason</th><td>EXCEPTION_ACCESS_VIOLATION</td>
            </tr>
            <tr>
                <th>Crash Address</th><td>0xffffffff81e00003</td>
            </tr>

            <tr>

	    <th>User Comments</th><td></td>
            </tr>
            <tr>
	    <th>EMCheckCompatibility</th><td>False</td>
            </tr>
        </tbody></table>
    
      <div id="bugzilla">      
        <h2>Related Bugs</h2>

                                   <div class="bug_ids_expanded_list">
			                                        <dl class="sorted_bug_ids full">					  <dt>---</dt><dd><ul class="full_bug_ids full">
			        				      <li><span class="strike"><a href="https://bugzilla.mozilla.org/show_bug.cgi?id=578819" title="NEW --- crash [@ nsTransformedTextRun::SetCapitalization(unsigned int, unsigned int, unsigned char*, gfxContext*)]">578819</a></span> NEW crash [@ nsTransformedTextRun::SetCapitalization(unsigned int, unsigned int, unsigned char*, gfxContext*)]</li></ul></dd></dl></div>      </div><!-- /bugzilla -->
    
      <div id="frames">
               
            
            <h2>Crashing Thread</h2>
UNCOs, too; e.g. the *first* UNCO in each of these reports' "Related Bugs" table:

http://crash-stats.mozilla.com/report/index/61ee93a9-82ad-4ba0-b445-4d2ea2100427
http://crash-stats.mozilla.com/report/index/21a0bf25-7876-433c-b07a-7728d2100504
http://crash-stats.mozilla.com/report/index/de25f31b-2406-43f6-aa91-127aa2100428

The second UNCO in each report is listed as "open" and does not have strikethrough.

I wonder if this is a regression from the Bugzilla 3.6 upgrade, which added the "---" value to the Resolution column in bug lists for open bugs (it used to be blank/empty for open [UNCO/NEW/ASSI] bugs, and an actual resolution for RESO/VERI/CLOS)?
Keywords: regression
Summary: NEW bug is marked in class=strike → NEW, UNCONFIRMED bug is marked in class=strike
(Reporter)

Updated

8 years ago
Duplicate of this bug: 584248

Comment 3

8 years ago
Ryan, do you think you can take this on for 1.8?  (Otherwise 1.9 is fine)
Assignee: nobody → ryan
Target Milestone: --- → 1.8
Sure, I'll take a look.
Created attachment 462997 [details] [diff] [review]
Patch 1 for 578971

Bugs were only declared open if the resolution field was empty.  Bugs with a resolution of '---' were being declared closed.  This patch declares bugs with a status of UNCONFIRMED, NEW, ASSIGNED and REOPENED to be open.
Attachment #462997 - Flags: review?(ozten.bugs)

Comment 6

8 years ago
Comment on attachment 462997 [details] [diff] [review]
Patch 1 for 578971

Nice one! Thanks for the quick turn around.
Attachment #462997 - Flags: review?(ozten.bugs) → review+
Committing.

==

Sending        webapp-php/application/libraries/bugzilla.php
Transmitting file data .
Committed revision 2315.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Updated

8 years ago
Duplicate of this bug: 584994
Verified FIXED on http://crash-stats.stage.mozilla.com/report/index/5b9343ac-8515-4cee-a9a0-1c5d82100826; no strike (strikethrough) on the NEW bugs there.
Status: RESOLVED → VERIFIED
OS: Mac OS X → All
Hardware: x86 → All

Updated

8 years ago
Duplicate of this bug: 592333
Merge to 1.7.6
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Target Milestone: 1.8 → 1.7.6
Committing for 1.7.6:

Sending        webapp-php/application/libraries/bugzilla.php
Transmitting file data .
Committed revision 2712.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
Flags: in-testsuite?
Component: Socorro → General
Product: Webtools → Socorro
Component: General → Webapp
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.