uncaught exception in filepicker.js

VERIFIED FIXED in mozilla1.0

Status

()

Core
XUL
P3
minor
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Tom Everingham, Assigned: Brian Ryner (not reading))

Tracking

(Depends on: 1 bug)

Trunk
mozilla1.0
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Overview Description:  I am getting an unhandled exception message when clicking 
a dangling symbolic link 

Steps to Reproduce:
1.)  Set up a directory with a symbolic link that does not point to anything.  
ie. delete the file it points to
2.)  click on the link

Actual Results:  I get the following javascript error in the console.
JavaScript error: 
 line 4: uncaught exception: [Exception... "Component returned failure code: 
  0x80520006 [nsIFile.isFile]"  nsresult: "0x80520006 (<unknown>)"  
  location: "JS frame :: chrome://global/content/filepicker.js :: onSelect 
  :: line 314"  data: no]

Expected Results:  should be handled (as in windows) as an error box with a file 
not found message.

Build Date & Platform Bug Found:  Linux rh6 10/24 branch

Additional Builds and Platforms Tested On:
Works on winNT

Comment 1

18 years ago
Somewhat related to bug 56779 - adding bryner to CC.
Summary: uncaught exception in filepicker.js → uncaught exception in filepicker.js

Comment 2

18 years ago
does this need to be rtm?  Looks like just an error is written out?

Comment 3

18 years ago
We could try/catch the isFile() and isDirectory() calls, but those should really
not be giving that (known) error to start with.

bryner?
(Assignee)

Comment 4

18 years ago
I agree.  This is a problem with followLinks not being honored.  When I get
around to filing a bug for that, I'll mark this one as dependant.
Assignee: don → bryner
Component: XP Apps → XP Toolkit/Widgets
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Depends on: 57995
(Reporter)

Comment 5

18 years ago
I don't think it should be rtm'd.  You would run into this rarely.
(Assignee)

Updated

18 years ago
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 6

17 years ago
This exact exception is no longer applicable with the outliner rewrite, but
there's an analogous one which I've filed as bug 82832.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
no longer see this in verif builds. see the exception noted in bug 82832 in
debug builds, though.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.