Closed Bug 57906 Opened 21 years ago Closed 17 years ago

:root element grows to fit contents [BG] (stretches)

Categories

(Core :: Layout, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: ian, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: css2, regression, testcase, Whiteboard: [Hixie-P2])

Attachments

(2 files)

When the HTML has content that extends outside of its content area the HTML
element's frame is getting sized as wide as the content. This should not 
happen. The content that overflows should be subject to the 'overflow' policy 
of the parent element.

STEPS TO REPRODUCE:
   View the attachements.

EXPECTED RESULTS:
   The outer blue border (the HTML element) should be the width of the viewport.

ACTUAL RESULTS:
   The outer blue border goes off theright hand side of the window.

That's not how it should work in CSS. Because the HMTL's width is specified as 
'auto' it is computed based on the viewport width, and that is the final value. 
Regardless of whether content overflows.

This broke out of bug 35681.
See bug 15405 for the vertical case.
QA Contact: petersen → ian
Summary: :root element grows to fit contents → :root element grows to fit contents [BG]
Target Milestone: --- → Future
*** Bug 35681 has been marked as a duplicate of this bug. ***
Is this the same problem as described in Bug 36338 (text wraps beyond window if 
HR width is larger than window)? Just want to make sure because it was marked a 
duplicate of Bug 35681 (the originator of this one) and it's still not fixed. If 
it is the same, the very simple test case there may be helpful.
Bug 36338 is fixed.
Status: NEW → ASSIGNED
Target Milestone: Future → mozilla0.9
Keywords: mozilla1.0
->moz1.0
Target Milestone: mozilla0.9 → mozilla1.0
Whiteboard: [Hixie-P2]
According to http://bugzilla.mozilla.org/duplicates.cgi this bg has 10 dups.
Marking mostfreq.
Keywords: mostfreq
Summary: :root element grows to fit contents [BG] → :root element grows to fit contents [BG] (stretches)
->boris for fun
Assignee: eric → bzbarsky
Status: ASSIGNED → NEW
Target Milestone: mozilla1.0 → Future
Keywords: css1css2
Priority: P3 → P4
No plans to work on this any time in the foreseeable future, so to default owner.
Assignee: bz-vacation → nobody
QA Contact: ian → core.layout
Priority: P4 → --
Target Milestone: Future → ---
Blocks: 228942
Keywords: mozilla1.0
QA Contact: core.layout → ian
Depends on: 241694
Fixed by checkin for bug 241694.
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.