Closed Bug 579141 Opened 11 years ago Closed 11 years ago

libangle fails to build on Ubuntu 10.x with GCC 4.3 & 4.4, with e.g. "throw_gcc.h:86: undefined reference to `mozalloc_abort(char const*)'"

Categories

(Core :: Canvas: WebGL, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 578938

People

(Reporter: dholbert, Unassigned)

References

Details

Attachments

(2 files)

Bug 571172 broke my builds on both:
  Ubuntu 10.04   / GCC 4.3.4
  Ubuntu 10.10a2 / GCC 4.4.4
with errors like:
{
> Initialize.o: In function `std::__throw_logic_error(char const*)':
> /obj/gfx/angle/../../dist/include/mozilla/throw_gcc.h:86: undefined reference to `mozalloc_abort(char const*)'
> Initialize.o: In function `std::__throw_length_error(char const*)':
> /obj/gfx/angle/../../dist/include/mozilla/throw_gcc.h:104: undefined reference to `mozalloc_abort(char const*)'
> Initialize.o: In function `operator delete':
> /obj/gfx/angle/../../dist/include/mozilla/mozalloc.h:250: undefined reference to `moz_free'
> /obj/gfx/angle/../../dist/include/mozilla/mozalloc.h:250: undefined reference to `moz_free'
> /obj/gfx/angle/../../dist/include/mozilla/mozalloc.h:250: undefined reference to `moz_free'
> /obj/gfx/angle/../../dist/include/mozilla/mozalloc.h:250: undefined reference to `moz_free'
}

This is a debug --disable-lixbul build, in both cases.  I think this is a known failure, but I don't think there's a bug filed on it yet, so I'm filing one here.
Summary: libangle fails to build on Ubuntu 10.x with GCC 4.3 & 4.4, with "throw_gcc.h:86: undefined reference to `mozalloc_abort(char const*)'" → libangle fails to build on Ubuntu 10.x with GCC 4.3 & 4.4, with e.g. "throw_gcc.h:86: undefined reference to `mozalloc_abort(char const*)'"
Here's the build failure log, with all the build errors. (the chunk in comment 0 was just a sampling)
For anyone else hitting this problem, here's a workaround for getting local builds to work (based on http://hg.mozilla.org/mozilla-central/rev/42029b6d627e)
(In reply to comment #0)
> I think this is a known
> failure, but I don't think there's a bug filed on it yet, so I'm filing one
> here.

Oh, sorry -- looks like there was a bug filed after all -- I think this all covered by the first bullet point ("libangle fails to build...") in bug 578938 comment 0.

Duping; if that bug's patches don't happen to fix this issue down the road, I'll un-dupe.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 578938
You need to log in before you can comment on or make changes to this bug.