Closed Bug 579352 Opened 12 years ago Closed 12 years ago

Firefox 4.0 b1 Freezes when using NetApp filerview

Categories

(Core :: DOM: HTML Parser, defect)

2.0 Branch
x86
Other
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 646157

People

(Reporter: jason.whipp, Unassigned)

Details

(Whiteboard: [CLOSEME 2011-05-30])

Attachments

(1 file)

15.24 KB, application/octet-stream
Details
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:2.0b1) Gecko/20100630 Firefox/4.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:2.0b1) Gecko/20100630 Firefox/4.0b1

OS Used: Windows XP, Fedora 13

Firefox 4.0 b1 consistently completely crashes when using NetApp filerview.

Our NetApp is running Data ONTAP Release 7.3.1.1P3  

I know this might be a difficult one to confirm, but I'm willing to test it.  I need firefox to play nice with NetApp.

Reproducible: Always

Steps to Reproduce:
1. Log into filerview
2. Click on the filerview icon
Actual Results:  
Firefox hangs and must be killed.

Expected Results:  
Should proceed to the shares/volumes/etc view.

Something to note is that the filer uses a self-signed cert.  But I've been on other sites that have self signed certs or mismatches that don't crash the browser.
Same result in safe mode.

I just noticed that I forgot the 3 reproduce step, after clicking the file view icon, you can from here click on volumes, shares, etc.

Firefox hangs when you attempt go into the detail of a configuration, e.g. ->  NFS -> Manage -> click on an export to manage.
Can you try to create an attach a stacktrace using this instructions:
https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg

Please attach it using the "add an attachment" link in this bug page.
Do you have Linux instructions? That's what I'd be using in a test.
I'm sorry but we have only links to different Distribution instructions for crashes available.
- https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report#Linux
 
I don't know if they describe the hang/freeze case.
Can reproduce this here too. in the filerview web page of the netapp filer goto  volumes -> manage and tick any check box. firefox hangs. as if its stuck in a loop
Attached file stacktrace
stacktrace from 2010-09-29 nightly build
Same with FF 4.0
Reporter, are you still seeing this issue with Firefox 4.0.1 or later in safe mode or a fresh profile? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2011-05-30]
Just tested with 4.0.1, not seeing the issue.  Tested with logging in and browsing the main filer view page as well as drilling down into volumes, nfs, cifs, etc. 

I'd say this has been resolved.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
I'm afraid it still happens to me. FF 4.0.1, safe-mode, no adds-ons. I've also tried with a new profile, and selecting one volume makes FF freeze.
One thing I negated to mention is that my test yesterday was on Fedora 14 x64 with FF 4.0.1 32bit.  

I just tested again.

First time I was able to duplicate; navigate to the filer view and click on a volume, hard lock.  

A subsequent 2nd and 3rd test could not duplicate.  I'm wondering if it has something to do with how long FF has been running.
Thanks to Ed Morley [:edmorley] (bug 644540) I can say that setting "html5.parse.enable" to false seems to solve the problem. What now?
disabling the html5 parser is no solution
Status: RESOLVED → UNCONFIRMED
Component: General → HTML: Parser
Product: Firefox → Core
QA Contact: general → parser
Resolution: WORKSFORME → ---
Version: unspecified → 2.0 Branch
If this case doesn't involve deeply nested labels, please reopen.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 646157
You need to log in before you can comment on or make changes to this bug.