If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"Tabs on Top" results in clumsy-looking Aero effects due to wrong width

RESOLVED DUPLICATE of bug 554982

Status

()

Firefox
Theme
RESOLVED DUPLICATE of bug 554982
7 years ago
7 years ago

People

(Reporter: Paul Buonopane, Unassigned)

Tracking

Trunk
All
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.1; Win64; x64; en-US; rv:2.0b2pre) Gecko/20100714 Minefield/4.0b2pre
Build Identifier: Mozilla/5.0 (Windows; Windows NT 6.1; Win64; x64; en-US; rv:2.0b2pre) Gecko/20100714 Minefield/4.0b2pre

When "Tabs on Top" is enabled, the toolbar area falls three pixels short on the left and right of the inner Aero border edge.  This looks rather clumsy, and makes it obvious that Aero is extended down below the toolbars, despite them being opaque.  In addition, the toolbar area appears to cut off rather abruptly, which increases the notability of the offset.

Reproducible: Always

Steps to Reproduce:
Enable "Tabs on Top"
Actual Results:  
Toolbar area falls three pixels short of the inner Aero border edge on the left and right, and the border does not match the Aero border.

Expected Results:  
The toolbar area should extend horizontally to meet the outer edges of the the inner Aero border.  The last two pixels on either side should match the color and opacity of the Aero border.  In addition, slightly rounding the upper corners (even if the radius is just a pixel or two) could decrease the notability of the problem.

This problem has existed since the Aero theme was first implemented in the nightly builds.  It continues to live on in the first beta release of 4.0 and the corresponding nightly builds.  Confirmed to occur on Windows Server 2008 R2, Windows 7 x64, and Windows 7 x86.
(Reporter)

Comment 1

7 years ago
Created attachment 457912 [details]
Current appearance of Tabs on Top
(Reporter)

Comment 2

7 years ago
Created attachment 457913 [details]
Expected appearance of Tabs on Top
(Reporter)

Updated

7 years ago
Version: unspecified → Trunk
(Reporter)

Comment 3

7 years ago
This is still very much a problem
Severity: trivial → normal
Depends on: 592182
Hardware: x86_64 → All
(Reporter)

Comment 4

7 years ago
With the regression outlined in bug #592182, this also applies to tabs on the bottom.  Prior to the regression, this bug only applied when "Tabs on top" was enabled.

Comment 5

7 years ago
This is a duplicate of bug 588764 (or what ever bug is split off per https://bugzilla.mozilla.org/show_bug.cgi?id=588764#c49 )

Note that in more recent builds, this is much better and just needs the border fixed.

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 554982
You need to log in before you can comment on or make changes to this bug.