Download manager bug needs core development help

VERIFIED DUPLICATE of bug 301328

Status

Core Graveyard
File Handling
--
major
VERIFIED DUPLICATE of bug 301328
8 years ago
2 years ago

People

(Reporter: charlie, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6
Build Identifier: All

There is a long-standing download manager bug, Bug 301328
which has persisted 5 years without being addressed.

More help is needed to fix, and probably a change in the core app link handling that initiates the download manager, therefore I am filing this bug here as well.

https://bugzilla.mozilla.org/show_bug.cgi?id=301328


Reproducible: Always

Steps to Reproduce:
1. Download a file like report.pdf
2. Download newly updated file report.pdf
3. click download manager link to open the new file.
Actual Results:  
Download manager link opens the wrong file. The second file was actually saved as report-2.pdf but the link points to the first file report.pdf.

Expected Results:  
Before or during download manager startup, user input should be requested to confirm filename and possibly illuminate filename conflict before the download begins.
We know that it needs help, but filing additional bugs isn't going to get it that help.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 301328
Filing more bugs doesn't help, it's only a waste of our resources.
If you want a bug fixed you can always attach a patch
Status: RESOLVED → VERIFIED
(Assignee)

Updated

2 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.